Repository brave-browser does not define additional 'gpgkey=' URLs


Description of the issue:
I have tried installing Brave iaw the OpenSUSE 15+ instructions here:
I have spent two hours searching for a solution to a gpg key missing issue. I have found several solutions but none of them have fixed it.
How can this issue be reproduced?

1.Try to install brave browser into OpenSuse tumbleweed following OpenSUSE 15+ instructions here:

Expected result:
Brave browser installed and operating
Brave Version( check About Brave):
Additional Information:
What does this mean and how do we fix it?
gecko:~ # zypper install brave-browser
Loading repository data…
Reading installed packages…
Resolving package dependencies…

The following 4 NEW packages are going to be installed:
at brave-browser brave-keyring libHX32

4 new packages to install.
Overall download size: 87.5 MiB. Already cached: 120.3 KiB. After the operation, additional 87.7 MiB will be used.
Continue? [y/n/v/…? shows all options] (y): y
In cache libHX32-3.26-1.1.x86_64.rpm (1/4), 48.0 KiB ( 75.2 KiB unpacked)
In cache at-3.2.2-1.1.x86_64.rpm (2/4), 61.6 KiB (119.2 KiB unpacked)
In cache brave-keyring-1.9-1.noarch.rpm (3/4), 10.6 KiB ( 10.6 KiB unpacked)
Retrieving package brave-browser-1.29.81-1.x86_64 (4/4), 87.5 MiB ( 87.5 MiB unpacked)
Retrieving: brave-browser-1.29.81-1.x86_64.rpm …[done (28.2 MiB/s)]
Header V4 RSA/SHA512 Signature, key ID a8580bdc82d3dc6c: NOKEY
V4 RSA/SHA512 Signature, key ID a8580bdc82d3dc6c: NOKEY

warning: /var/tmp/AP_0xlQphmf/brave-browser-1.29.81-1.x86_64.rpm: Header V4 RSA/SHA512 Signature, key ID 82d3dc6c: NOKEY
Looking for gpg key ID 82D3DC6C in cache /var/cache/zypp/pubkeys.
Repository brave-browser does not define additional ‘gpgkey=’ URLs.
brave-browser-1.29.81-1.x86_64 (brave-browser): Signature verification failed [4-Signatures public key is not available]
Abort, retry, ignore? [a/r/i] (a): a
Problem occurred during or after installation or removal of packages:
Installation has been aborted as directed.
Please see the above error message for a hint.

Hello – did you also do the immediately preceding steps from that doc:

sudo zypper install curl

sudo rpm --import

If so, did you get any error messages when doing so?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.