Reporting a Bug :

I’m here to report a bug, when using speedreader, brave crashes automatically without saying anything else.
I have Windows 10 21H2 Pro, latest version of brave (1.42.86).
Nothing else to say, I hope you’ll do good job to solve it.


Does crashing still persist:

  1. If Extensions are disabled or
  2. In a newly created profile?

I’m also curious whether or not it crashes the browser when being used on any site or only for specific sites?


I confirm the report: since my last Brave update, when I use speedreader, Brave crashes.
This happens both on websites I usually visit and on websites I never visited before.

I don’t have any extension installed and I already tested on a new profile: the problem persists.

I have not yet found a speedreader compatible website that works well.
Version : Brave 1.42.86 with Manjaro Linux 5.15

Hey there!

Thanks for this feedback! Brave desktop was constantly crashing for me too and that seems to be the cause.

Disabled Speedreader and the links that use to crash the browser now open without crashing it.

I am on win10 and I use Speedreader. I am not experiencing this problem.

If possible, could you provide links to some example websites that were crashing? It will provide additional information for support staff and I want to test to see if I crash too on those sites. :slightly_smiling_face:

Of course, here are two recent links on which my computer crashed:

Are you working with the same version of Brave ?

1 Like

@JustReportingABug, @js021, and @brvc could you do a favor?

  • Go to brave://crashes
  • Check the box on the top right of the screen that says Show Developer Details
  • Send your more recent crash related to your issue.
  • Copy your Uploaded Crash Report ID:
  • Share the Crash Report ID here.

This should help provide more insight that @Mattches and developers may need for the issue.

If you don’t see anything listed there, you may need to go to brave://settings/privacy and make sure you have Automatically send diagnostic reports enabled. I forget if it saves crash reports regardless or if you need to turn that on. In any case, definitely will provide more insight.

Of course, here it is:

Date et heure du plantage : dimanche 7 août 2022 à 19:32:16
État :	Importation terminée
ID du rapport d erreur importé :	5ba20300-efc0-a008-0000-000000000000
Heure de l importation :	dimanche 7 août 2022 à 19:38:51

I had to crash it again to get the ID…

The issue was reported 2 days ago on github #24479.

My report: #24494

1 Like

Nice, I hadn’t gone through that. I see the two separate, both look to be User submitted issues. Duplicate topics/issues usually aren’t liked by any means, so ideally would have searched and added to an existing.

At least bringing it up here is going to have it for Mattches and whoever else to be able to see it and handled.

1 Like

@brvc @js021
TL:DR For me, works as expected on all sites tested. :slightly_smiling_face:

I was able to go to the two https:// sites with no problems. Disabling/enabling Speedreader and clicking the Show original page link all worked with no problems. I am on the latest version of Brave, 1.42.88.

Sites checked:


The first time I tried the http:// site it would not load. Gave me the “Not secure” message as expected. However, clicking “Continue to site” did nothing. I closed that tab and tried again and it loaded without a warning the second time. As with the https:// sites, the http:// site worked fine with no problems.

  • [ ](

Edit: Sorry, I forgot to to @ js021. Corrected. :slightly_smiling_face:

1 Like