Rendering Issue

Description of the issue:
Periodically new tabs won’t render at all and existing tabs are stuck at their previous size. The only way to get either to render is to drag the tab out of the window into its own window. Resizing or refreshing has no effect. This behavior occurs with hardware acceleration enabled and disabled.

Opening tabs on a new window works as expected.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Cannot consistently reproduce. It may be related to sleep mode but I think it’s also happened a few times even without sleep. Chromium and Chrome with the same hardware acceleration settings do not act the same.

Actual Result (gifs and screenshots are welcome!):

(I scrubbed the page contents of PII before recording)

Expected result:

New tabs should always render and existing tabs should resize with the window.

Reproduces how often:

Inconsistent. May be related to sleep mode. Happens 2-3 times a week. (Using computer for 40+ hours).

Operating System and Brave Version(See the About Brave page in the main menu):

Arch Linux

|Brave|1.22.70 Chromium: 89.0.4389.105 (Official Build) (64-bit)|
|Revision|14f44e21a9d539cd49c72468a29bfca4fa43f710-refs/branch-heads/4389_90@{#7}|

Graphics Feature Status

  • Canvas: Hardware accelerated
  • Compositing: Hardware accelerated
  • Multiple Raster Threads: Enabled
  • Out-of-process Rasterization: Hardware accelerated
  • OpenGL: Enabled
  • Rasterization: Hardware accelerated on all pages
  • Skia Renderer: Enabled
  • Video Decode: Hardware accelerated
  • Vulkan: Disabled
  • WebGL: Hardware accelerated
  • WebGL2: Hardware accelerated

Driver Bug Workarounds

  • adjust_src_dst_region_for_blitframebuffer
  • clear_uniforms_before_first_program_use
  • decode_encode_srgb_for_generatemipmap
  • exit_on_context_lost
  • msaa_is_slow
  • scalarize_vec_and_mat_constructor_args
  • disabled_extension_GL_KHR_blend_equation_advanced
  • disabled_extension_GL_KHR_blend_equation_advanced_coherent

Hello @paco3346

could you disable all extension and try in private mode

if it work then the issue with one of your extensions or you need to clear cache/cookies

hope that help and have a nice day :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.