Removing secure window in url bar

i want this gone please, I have allowed everything, exceptions seem to not work at every turn,

What do you mean?

If you wish to visit the site in http, then go just ‘Accept the risk and continue’.

Or you can go to brave://settings/security and turn off ‘Always use secure connection’

what do I mean, ??? I mean I want the red flag-notice - beware crap gone, I should not have to click that “accept the risk” when I setup the site insecure settings in Brave to allow… smh, I want to be able to click the link and take me directly into the site, Brave won’t save passwords or login / user ID credentials…, I went into chrome and applied the exceptions and it is business as usual…(see below)
So in BRAVE, I need to be constantly reminded of my behavior?, I should not have to click to accept,then enter login and PW each time I visit, I should not have to click twice to even open up the link… . brave will have go along with a serious review of why, if it can not be changed.
It may not mean much to anyone but me, simplicity and dependability is best. Thanks to anyone that cares,
Brave if you are listening, fix it or just tell me you can’t and I’ll move on

Join the chrome club if you can’t get this to work in brave:

On your computer, open Chrome .

  1. At the top right, click More. Settings.
  2. Click Privacy and security. Site Settings.
  3. Click Additional content settings. Insecure content.
  4. Next to “Not allowed to show insecure content,” click Add.
  5. Enter the site’s URL.

I just want to ask for my own understanding and clarification. Questions on two different settings, which I think likely result in what you’re seeing. Both are in brave://settings/security but different settings.

Of the two, I think it’s #1 that’s resulting in your warning. So if you deactivate it, wouldn’t have a problem. But I’m throwing #2 in the mix in case it also plays a role.

  1. Photos 12_7_2022 10_13_09

And then maybe:

1 Like

Saoiray |

  • |

Thank you for caring and responding

I deactivated #1, no change # 2 was already deactivated

this should not be that difficult. the site in question is my site, So there is entirely no risk, since no one knows of the link within my site
I only use it for my benefit , it accesses a database I have built on it, tired of the uncooperative brave in this matter , been using brave for years, 4 days ago I dropped my SSL Cert on the site just because there is no need for the added expense of having it, especially for what I am using it for. it is no longer a “public site” so to speak, Brave does well on every other web interaction… but this particular issue is a deal breaker because purely it wants to control “my behavior” instead of honoring my choice of behavior.,it’s acting like a rogue malware/virus protection agent.

simply put,

seriously man, I really appreciate the thought

I actually might have found the solution as I was searching. Solution would be coming from if you want to see it yourself. Otherwise, steps listed below:

  1. Go to brave://flags

  2. Search Insecure

  3. Enable Insecure origins treated as secure

It shows as if you can put in the custom websites you want for it. It doesn’t seem to work on a global scale, if I’m seeing it right. If you want to go that step further, you may want to tag Mattches in and see if he can answer. But at least think I might have been able to get you this far. Hopefully at least solves it for your site if you do that.

I had tried that as well brother, tried again, no luck…

enabled it, added my site, relaunched it , same ol, same ol



@Mattches, would you happen to have any ideas or is this just something more permanent from upstream that can’t be toggled?

I’m confused — this exact same setting exists in Brave as well. Are you saying that following the same instructions in Brave does not result in the warning being removed? Or what is the exact behavior when you follow the same steps as you do in Chrome in Brave?

the exact same setting in chrome and brave, are NOT the same results,

in chrome there is NO Red Triangle, no https strikethru,it is as if there is an SSL cert, stores credentials,
In brave, I get the website, no stored ID or PW, but red triangle (Not Secure) and https in red with a strikethru

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.