Remove 'sphere' tab from new page

Recently In new tab the ‘sphere’ tab appears. How to get rid of it?

Until someone replies who already knows what a “sphere” tab is, could you take a screenshot of that? And are you running the latest release version? (v.0.66.100)

Sorry, I though this is the same for everybody.

And, this is the latest version.

If I click this, I see:

Does this happen every time you open a new tab or just when opening a new window? This is definitely not normal behavior.

Could you go to chrome://settings/getStarted and check what is selected here:image

This happens on every new tab.
For new tab the ‘Awesome new page’ extension is selected, but I have the same in Torch browser and there’s no this filth.

It’s very likely caused by the extension. On it’s Chrome web store page, it also says “Sphere personalized content discovery experience”.
Try right-clicking on the extension button next to the navigation bar, then click “options”. Does this open the options?

Yes, it seems to be some issue between the extension and Brave.
The ‘option’ opens and I can set the background as I wish. The same as in Torch, with the only difference that here this ‘Sphere’ appears on top of my selected background.
I’ve tried four different adblockers if they remove this but they don’t.

But you can’t close the options window and view the buttons on the left side of the screen? (Make sure they are activated in Options > General > Always show left buttons)

You could also try to press the reset button.

I can’t find Options > General > Always show left buttons, nor anything on the left side.
I only see this:

I was referring to the extension’s options.

Can you see those buttons on the left? (Maybe after enabling them as seen on this picture?)
If you cannot see them, you could try the reset button.

Oh yes, this made the trick.
Thank you very much!

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.