Remove new circles around tab favicons?

Tab favicons are too small with these dumb circles. Eg: image

This forum topic suggests there’s a flag brave://flags/#memory-saver-discarded-tab-treatment
but this flag has disappeared in newly upgraded version: 1.64.109

Any ideas? The quantity of forum topics about this suggests these circles should be disabled by default when memory saver is on. Most Brave users shouldn’t care whether tabs are inactive, as long as their machine doesn’t crash due to high memory consumption.

Flag exists on another machine of mine running Brave 1.63.174, but downgrading to it doesn’t reinstate. Must be some other underlying expiry of this flag that has kicked in.

Agreed - the favicons end up being so small as to be unrecognizable, often. I like the idea of expired tabs, but please let’s find other ways of showing it, or have the option of not showing it.

1 Like

“downgrading to it doesn’t reinstate” - I don’t think I downgraded correctly. I just tried again, uninstalled 1.64.109 and installed 1.63.174 using:
https://github.com/brave/brave-browser/releases/download/v1.63.174/BraveBrowserStandaloneSetup.exe

and brave://flags/#memory-saver-discarded-tab-treatment is back. Set to disable, and no more illegible tab icons :slight_smile: Just have to hope Brave doesn’t auto-upgrade. Wonder if there’s a way to prevent…

“Wonder if there’s a way to prevent…”. On Windows can disable the Brave Update Service. Brave still nags you to update on exit, choose no. Set a reminder in some months to re-enable this service, hopefully by then there’ll be a proper way to remove these janky inactive circles.

I’m from the other thread-- I don’t want circles, I want visible favicos. :frowning:

At firs: I would never recommend disabling the automatic update service. Instead, talk to people here in the forum, maybe you and others can make a change for the next update.

Back to topic:

Can you try to update your browser to the newest version?

On my machine, I use a Fedora Linux 39 with brave version Version 1.64.113 Chromium: 123.0.6312.86 (Official Build) (64-bit) installed. The only website I recognized those circled favicons is the https://search.brave.com.

On other websites I see the favicons in full size no matter if it’s round, a square or something else.

If I misunderstood your situation, please don’t hesitate to push me in the right direction.

Examples:

Uphold
image

Google
image

YouTube
image

Brave Search
image

Only exception here is brave search as mentioned above.

They’re probably not inactive @LxWulf. Don’t touch Brave for a couple of hours and you’ll see them unless you have brave://flags/#memory-saver-discarded-tab-treatment disabled.

Okay, I can confirm this. Despite that, I don’t see that big of a problem here, also there is already a solution to it if you disable the memory function. You don’t need to set the flag.

Go to brave settingsSystem (No.1) and then the last entry you see, is the Perfomance settings.

For sure, you can go directly to the setting with brave://settings/system

There, you can disable the Memory Saver function (No.2) or adding your favorite websites to the whitelist (No.3), so those websites never go into the inactive state.

Reference:

I admire your positivity LxWulf, but we aren’t all blessed with an abundance of memory, or a rigorous discipline to avoid using many tabs.

1 Like

Thank you. :blush:

I do understand. Despite, I do not have any hope that this changes soon, but you can still move your post to the Feature Request section here or create a new one there.

Steps if you want to move your post:

  1. Go to your initial posting.
  2. Press on the edit pen at the end of your post title.
  3. Click on the set topic.
  4. Change it to Brave Feature Requests Desktop Requests
  5. Remove your tags on the right side of the topic selection.
    1. In your case, this would be the browser tag you need to remove.
  6. Save it and you’re done. Your post is now in a new topic section.

Notice:
If you decide to create a new post do not forget to mark this post as “solved” and maybe add the link to the new post if you want, you don’t need to do this though.