Removal of frequently visited site from opening page list

Everyday I visit Bitchute and watch videos there. I therefore have Bitchute listed among my frequently visited sites on the opening page of my Brave Browser, and yet almost everyday the Bitchute link is removed and replaced by other sites I visit a lot less than Bitchute, or rarely visit at all. I want to know why this is happening given that Bitchute is clearly among my top 5 sites. Why does the browser keep removing Bitchute from my front page list of frequently visited sites when I go there every day and replace it’s link with sites I rarely visit?

@MzT,
Thank you for reaching out. Can I ask what version of the browser you’re currently using?

Version 1.24.85 Chromium: 90.0.4430.212 ( Official Build) 64 bit

@MzT,
Can you confirm for me that you don’t have any data set to be cleared “on exit” in Settings --> History --> Clear browsing data --> [On exit]?

Yes, nothing in the “on exit” area is checked. Interesting that this morning I had two websites I never go to replace the one I go to almost every day, as I have been describing to you. I just keep clicking on “remove” until I get back to the one I want. But it is bizarre, given that as I mentioned I go to Bitchute just about every day. I must have removed at least 10 website links by now. As I said, it is a regular occurrence removing these rarely visited sites so I can have a top 5 list that reflects the actual places I visit on the net.

@MzT,
That is very strange. Let me do some digging and see what I can find out about this. In the meantime, can you tell me if you have any extensions installed at this time?

Yeah, I have Adobe Acrobat and Google Translate listed in extensions.

@MzT,
Apologies for the late reply, just getting back from the weekend. So I didn’t see an open issue for this, however I am wondering if it’s related to this one:

I’ve asked some team members currently working on the NTP for their input as well. Thank you for your patience.

hmmm that’s interesting, although generally I just click on the link to open it in the same page, so not sure of that issue would apply. I did just open Bitchute in another tab, and then opened again in another tab after that …not sure if that will do anything but hey it’s worth a try. And yeah, it’s obviously not a major issue but I appreciate you looking into it. thanks.

I must have removed about 6 or 7 old web site links this morning before the Bitchute came back. But I will just keep doing that. The whole thing’s a bit bizarre though. And I hope there is nothing nefarious in it. Why only Bitchute, and no other linked sites?

@MzT,
That’s a great question – I don’t know why it’s only doing this for Bitchute. I’m wondering if clearing your browser cache might shake something loose here. I can’t see any reason why you would be seeing this behavior – especially if it’s only for the one site.

ok I will try clearing my browser cache and see what happens. Also, I had no recurrence of the issue today after yesterday’s 6 or 7 in a row.