Removal of autofill entries (Linux, esp. Debian/Ubuntu)

I am an OSS user and primarily use Debian Linux derivatives, mainly flavours of Ubuntu.

Once upon a time, when using Brave to log on to my local NAS box I accidentally typed in the password into the Username box. This was squirrelled away by Brave for future reference, bringing up the implicit VISIBLE “drop-down” of options when logging on, which is Very Bad. The drop-down options themselves is fine and may even be really helpful, but not when it’s contaminated by such private information and may lead to observation by others, as well as cluttering up the option list itself. So, I wished to remove it, but nothing I found in the Brave Help would actually do that, including clearing of browsing data (short of resetting the whole lot, which I did not try as the consequences are Terrible!).

I found this post here: https://community.brave.com/t/how-to-clear-delete-autofill-entry/260700 which was Windoze-focused but gave me an insight as to how to solve the problem, thankfully.

So, here is an outline of the solution I’ve crafted, slightly complicated by the use of Snap for Brave:

  1. Copy the instructions for reference :wink:
  2. Close the Brave browser
  3. If you haven’t one installed already, install an SQLite 3 database editor, for example “sqlitebrowser”, which is what I used, installing from the command line using

sudo apt-get install sqlitebrowser

Other methods of installation are available, and you can find options with a quick internet search… If you ONLY use Brave, then I guess doing that before you close it would be a Good Plan!!
4. Ideally, make a backup of the database you’re going to modify, which is, under your home directory:

“snap/brave/current/.config/BraveSoftware/Brave-Browser/Default/Web Data”

  1. Open DB Browser for SQLite, which is a graphical browser.
  2. Click on “Open Database”.
  3. Click on the cog icon at the top right-hand corner of the “Open a database file” dialog box and ensure that the “Show Hidden files” checkbox is CHECKED.
  4. Navigate through to the directory:

Home → “snap/brave/current/.config/BraveSoftware/Brave-Browser/Default”

  1. Ensure the “Filter” at the bottom of the dialog box is set to “All files”.
  2. Probably the last file in the displayed list is “Web Data”. Select it and click “Open”.
  3. Click on “Browse Data”, the second tab in the second row to the top of the window.
  4. Find the information, stored in the “value” column, and select that row by clicking on the number to the left of the row.
  5. Right-click and select “Delete record”.
  6. Click on “Write Changes”, the third tab on the top row in the window.
  7. Close DB Browser for SQLite.
  8. Open Brave and… voila!

I hope this helps! Good hacking!

Hugs for now,
Tigger

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.