Recent Mac Update SERIOUS Browser Issue


#1

Hi Mac user here; downloaded the new version earlier this morning and restarted browser. Upon restarting browser I have been unable to utilize or access new tabs even though they appear in the browser. Cannot even access “about” or “preferences” [or anything along those lines] because they open in new tabs thus preventing access. I have restarted the browser multiple times and attempted to open bookmarks and other things with no success.

Please let me know how I can assist or provide you information that could assist with this issue. I enjoy using brave and wish to continue using it, however with this update I will be unable to.

Thank you!


#2

Hi @da.stoic

What version of MacOS and Brave do you have?

Thanks,
Lauren


#3

10.11.6

Hi, I’m experiencing the same problem.
I just updated the browser and now everything seems broken.
Can’t drag my bookmark pins around anymore unless the whole browser freezes.
Can’t copy anything now and paste. I tried right click “copy” and then paste - nothing happens.
Also tried command+c as I always use and then command+v and still doesn’t work.
What happened?!
Can I roll back the update?


#4

Hi @anamnesia

Are you able to open a new tab and go to about:brave

I want to verify the Brave version you’re on is 0.18.29.

Thanks,
Lauren


#5

Also @da.stoic and @anamnesia - if you are able to open Developer Tools and select ‘Console’ - if there are any errors there could you copy/paste them to here please?

Thanks!
Lauren


#6

I had the same issue after updating today. OSX 10.11.6 and Brave 0.18.29. However, now a few hours later when I opened up Brave everything worked as usual, no issues. I’m not able to replicate the issue.

The issue was that I could create new tabs but I could not switch to them or close them. I couldn’t open preferences either. Tried restarting, which allowed me to use the single tab on open, but the problem remained with new tabs.


#7

We did have a couple bad preview versions, if you are set to get preview updates (in preferences) it’s possible this is what happened. Updating to 0.18.29 should resolve this issue.

You can delete Brave from your Applications folder and download 0.18.29 from our GitHub repo (https://github.com/brave/browser-laptop/releases/tag/v0.18.29dev - grab the Brave-0.18.29.dmg file) and this should solve your issue.


#8

Yes that’s the right version I have.


#9

I want to try this, but last time I reinstalled Brave I lost all of my millions of bookmarks lol
And I tried to save the bookmarks but it wouldn’t save.
And I have quite sophisticated bookmarks I don’t want to spend two hours recreating.


#10

Hi @anamnesia if you want, first open a finder window and navigate to /Library/Application Support/ - then copy your brave folder (rename it to something like Brave1 or BraveOriginal). This way you still have a copy of all of your data.

Thanks,
Lauren


#11

Cool I’ll give it a shot thanks for your support!


#13

Same problem here on iMac; latest version of both.

Can it be that after the new Brave version Flash isnt, thus freezing new tabs
downloaded and installed Brave-0.18.29.dmg file from GitHub, restarted but still no luck. I did however keep all my bookmarks so it’s not a correct uninstallation. Just removing it to the bin still leaves everything there.
I thought I had it working but no. A site opened, a link from within that site as well but after that it all froze on me again


#15

Will cc-ing @sriram for additional answer.


#16

in the meantime I also contacted him and had additional info for him; the odd thing is that when I first open Brave I can’t open useable tabs there but when I click on a link in that first window for opening in a new window I can from that moment on open tabs. A bit of a puzzle


#17

I am having the same problem (serious bugs/breakage on new tabs) after updating to Brave 0.18.29 on MacOS 10.12.6.


#18

Addendum: Tab problem seems to be resolved after removing my prior user data folder from Library/Application Support/brave


#19

@LaurenWags: A neat short cut would be a javascript button for us to drag to the toolbar which would put a neat OS/Browser version summary on the clipboard for pasting here. Would make your job easier, i am sure.


#20

This sounds exactly like a problem I posted a few weeks ago


#21

I would like to try some parameters within OSX: --ignore-gpu-blacklist
Can some tell me how to add this to brave in OSX.
I’m using OSSierra latest.


#22

This is my second time having the same issue. All my pinned tab are not responsive after apply the updates.

Weird thing is, I try do drag one of my last open tab into another workspace, looks like all of my pinned tabs are response and it seems to work as usual.