ReCAPTCHA refuses to recognise Brave

Trying to purchase through eBay. Get to payment and it flicks to a reCaptcha page. Recaptcha whinges that I have to update to an approved browser, Chrome, FF etc. Brave apparently doesn’t pass the test, so recaptcha refused and payment stopped. Using Brave Version 1.38.109 Chromium: 101.0.4951.41 (Official Build) (64-bit).

Is there a way to fix this or maybe and extension to fake the latest Chrome credentials for this purpose? I have noticed the ‘update to an approved browser’ appearing more and more.

@Legion99 ,

All of the following steps, assume that you normally wish to have / leave Brave Browser > Shields: UP

Including the Global Shields Settings:


Therefore, you figure out what sources for cookies, and sources for scripts, are needed for access, and thus:

reCAPTCHA requires browser access to

With Brave Browser running, in a New Window, go to brave://settings/clearBrowserData

Examine all the settings for all three tabs: Basic / Advanced / On exit

Be certain that those settings are what they should be, for your usage. In time, you will have tested those arrangments, and figured out what you need, there.

Be certain for two of the tabs – Advanced / On exit – to Disable: “Site and Shields Settings” (unless, before the following steps, you decide that you initially do need to clear “Site and Shields Settings”).

IMPORTANT: The cleaning / clearing away of cookies, thru that (brave://settings/clearBrowserData) processing, MIGHT NOT REMOVE ALL of the cookies! If you are intent on removing all cookies, then you must also, in a New Window, be sure to go to: brave://settings/siteData and manually remove sources for cookies, if any, there.

Recommended at: brave://settings/cookies

  • Disable: “Clear cookies and site data when you close all windows”

  • Do not use: “Sites that clear cookies when you close them” (better to clear those cookie sources, manually: brave://settings/clearBrowserData)

Quit Brave Browser. Wait a moment. Start Brave Browser.

In a New Window, go to brave://settings/cookies

Scroll down that settings page, to Sites that can always use cookies

Click the Add button

Enter https://[*.] as the site . . . but do not Enable

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Repeat those steps for the following entries:

Next, go to brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter https://[*.] as the site . . . but do not Enable

  • Current Private session only

Click the Add button

Repeat those steps for the following entries:


I am uncertain: Where you will encounter the reCAPTCHA.

I am uncertain: If you use PayPal.

I added some extra entries, re allowing javascripts via the Shields global settings, above.

And I took a screenshot of the Shields (Lion icon) site-specific settings . . . having Allowed some, while still blocking others (about which, I am uncertain, and you may have to choose otherwise: ie Allow them, too) - my guess of what you may encounter, trying to sign in to eBay:

Thanks for all of that. I did as you suggested but cannot test it until I am going to purchase something through eBay. I finished the one earlier through the Android app. What your instructions have done though, probably me, is to kill my ability to log into Brave Community (I’m writing this in Chromium)
Instead of the normal page with lists and a log in facility I get this :point_down: with no log in facility.

Actually forget the last post - I fixed the log in thing by turning shields off for this site. I’ll leave it up in case someone else follows this.

Ok. No longer just ReCaptcha. Now Facebook is blocking Brave as well. This is no longer a glitch. This is now suppression of freedom to choose a browser.
Screenshot from 2022-05-07 09-26-11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.