Reading List "Add Current Tab" not working

When I open any tab (eg. Wikipedia) and open the Reading List, the “Add current tab” button is grayed out despite the list being empty (the tab is not already in the list).

Note: sometimes it does become blue, but I couldn’t figure out what causes it, sometimes it just starts working on the same tab it was gray before after opening&closing the sidebar and refreshing the page.


How to Reproduce

  1. Be me?
  2. Open any webpage (anything, from google to wikipedia articles.)
  3. Open the sidebar and (try) to save the tab to the reading list using the “Add to Reading List” button.

Expected Behavior

The button is blue, upon being clicked the website is added to the Reading List and the button becomes gray.

Brave Version( check About Brave):

Version 1.60.114 Chromium: 119.0.6045.124 (Official Build) (arm64)

Additional Information:

I am on M1 MacAir (I actually updated to MacOS Sonoma not so long ago), and I have tried relaunching and updating brave to the latest version. I have tested it on a new profile as well as guest mode with no extensions and default settings and the issue still occurs. It worked with no issues a week ago.

Edit: The button works if the reading list is opened before the url is entered into the tab, and doesn’t work if I attempt to add an already open website.

I have narrowed down on the problem a bit:

Better and more accurate issue replication guide:

  • Open any website (except a local file)
  • (Close) and open the Reading List sidebar by clicking the Reading List icon.
  • You will see the “Add Current Tab” button grayed out.

Note: the issue does NOT occur in the following cases.

  • If the sidebar was already open to the Reading List window prior to the webpage loading. (Note: reloading a website doesn’t affect an already grey button).
  • If the sidebar was already open to the Leo or Bookmark windows prior to the Reading List icon being clicked.

More information:

  • the issue occurs in both left/right/(non-visible) sidebar with always/mouseover settings. Using the “open sidebar icon” also causes the button to be grayed out.

Same issue on MacBook Pro running latest OS (Ventura 13.4.1), latest Brave (
Version 1.60.125 Chromium: 119.0.6045.199 (Official Build) (x86_64))

same issue on MBpro (13.6.1 ) Brave Version 1.60.125 Chromium: 119.0.6045.199 (Official Build) (x86_64)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.