Random text discoloration in Brave

Description of the issue:
About a week ago, I began to notice text becoming discolored while using Brave. By discoloration, I mean, text that should be black shows up as neon green or neon purple. It occurs randomly; when I first open a webpage, the text is usually the correct color, but when I move my cursor over the words, the text changes to a neon color. Or the reverse happens- the text might originally display as a neon color but when I move the cursor over the text, it changes back to black/normal. I first noticed this issue while using Gmail, but it began to happen when I opened other webpages as well, such as my school’s online learning system, Moodle. It does not happen every time I open a webpage, but it happens often enough to make me wonder why it is happening. Refreshing the webpage, closing the browser, and restarting the computer do not solve the issue. I checked for updates but my version is currently updated. It is also not my physical computer screen, because I do not have this issue while viewing text in Microsoft Word, or opening other programs on my computer (ex. Spotify).

Steps to Reproduce (add as many as necessary):
1. Open Brave
2. Go to gmail.com
3. Subject line of emails, body text of emails, really any text on the webpage (but not every piece of text) displays in a neon color.
4. Move cursor over the text
5. Color of text changes back to normal/black.
6. Remove cursor from the text.
7. Color of text goes back to neon.
Actual Result (gifs and screenshots are welcome!):

!
Expected result:
I expect the text to display in black consistently.
Reproduces how often:
Text will flip between black and neon color repeatedly depending on how often you move the cursor over the text.

Brave Version(about:brave):
brave%20version|396x500
Reproducible on current live release (yes/no):
Not sure…
Additional Information:
This issue isn’t urgent but it is odd and kind of annoying. Any help would be much appreciated! Thank you so much!

1 Like

Great report @kellndor!
I’m not seeing anything like this logged. I’m going to ask around and see if anyone on the team has input.

While I’m doing that, can I interest you in this?


Hello, I’ve had the exact same error on both the Brave and the Brave Beta browsers. Even after scanning my computer with Emsisoft and other anti-malware tools I haven’t been able to find a cause. Here are some pictures of how the errors appear to me, at this point Whatsapp Web is completely unusable.

I hope we can find a solution soon, all the best,

-Gerardo Rocha

@RochaGerardo, thanks for bringing this to our attention. Would you mind confirming that you’ve updated to the latest Beta release? Additionally, what OS are you using?

I have, here is my About Brave info tab:

And here is the info on my computer and OS:

If there’s anything else I can send to help I’ll be more than glad to do so.
Thanks for answering so soon, I know it’s a lot of work to keep up with the community and you guys are doing an excellent job.

Sorry for the late response! Try the following:

  1. Navigate to Brave://flags/
  2. Search for Force-color-profile
  3. Set this value to sRGB

Relaunch Brave and the discoloration issue should be resolved. Please let me know if you’re still encountering the behavior after flipping the flag.

Hello! I followed the steps and am sorry to report the issues continue, the bug has a sense of humor apparently because it showed like this upon relaunch:

The text fragmentation is also alive and well, here’s an example from Gmail:

I’ll report back if anything else should arise or if I find anything that can help

1 Like

Thanks for letting me know! Just reached out to Devs to see if there’s any other actions to be taken. Will update you when I know more.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.