Question: How do I set the double menu option to always display when using Brave search?

Description of the issue:
When I use Brave search, I usually see a menu above the search results that has All Images News Videos displayed as options (Image 1 below). Occasionally, and why I can’t determine, I see a menu with an additional submenu (Image 2 below).

  • I want to always see search result menus as in Image 2 below. How do I trigger or set this option to always display?

Brave Version (check About Brave):
1.37.116 Chromium: 100.0.4896.127 (Official Build) (64-bit)

Operating System:
Windows 10 Version 21H1 (Build 19043.1645)

Image 1:

Image 2 - How do I always get this menu/submenu option to display?:
image

Additional Information:

  1. I searched the community forums and could not locate a topic relating to this.
  2. I do not have any Custom filters in brave://adblock/.
  3. I thought the Help Center article below would provide the answer, but I do not have the “menu button” mentioned in the quote below displayed. Also, clicking on the lock icon in the search bar brings me to the search.brave.com Privacy & security details page in brave://settings and I couldn’t see a setting that would enable this function. I also checked brave://flags and didn’t find anything I thought might be relevant.

You can view and change Brave Search’s basic settings by clicking the menu button on the top-right of the page. From this menu, you can click See all settings to view all available options:

This is probably something really simple I am overlooking but I just can’t figure it out! Help. :smiley:

@Chocoholic ,

Brave Search (beta) in transition.

Re using https://search.brave.com/:

@289wk oooh, so this is only available in the Beta release atm? duh, I was probably using Beta when I saw it. AND… I had no idea that was part of the “Discussions” rollout and I read the articles and followed the links! Sheesh. Maybe I need to take a break. :wink:

Thanks @289wk :smiley:

Not sure what you mean by “Beta release” . . . so I clarified my previous reply.

The article said, if I remember correctly, “Discussions” was released in Nightly and Beta. I just took the leap.

Just went to Beta release and guess what…

Looking forward to the Brave Release version!

:heart_eyes:

@Chocoholic,
Brave Search itself is still in Beta — Discussions is available in Search by default at this time.

1 Like

@Mattches OK, just to clarify because I am getting confused again. :blush:

Is this statement correct?

The “double menu” display in Brave Search Beta is part of “Discussions” which is currently only available in the Brave Nightly and Beta versions of Brave Browser but will soon be available for the Brave Release version.

I believe it only disappears as you scroll down the page. Below, I’ve entered a query and started to scroll down through the results, observe that the additional options are not visible:

However, if I return to the top of the page, these options appear:

These options do not appear for me. Just tried again, made sure I was at the top of the page, and only the menu in Image 1 is displayed. Working in Beta though…

Going to go create a new profile and see what I get.

@Chocoholic ,

No relation between Brave Search Engine and the Brave Browser release versions:

  • Beta
  • Nightly
  • Stable

There are some javascripts involved

Brave_Search_Engine_scripts

The following host is used by a Brave Browser New Window, but not apparently needed (for the moment) by a Brave Browser New Private Window:

tiles.search.brave.com

1 Like

Hmmm, not clear why this is happening for you. I’m actually wondering if clearing your cache/data for search.brave.com might help?

I see these options no matter what on both Win10 and macOS systems (using Brave Release build (v1.37l116)).

Yep, works when I create a new profile.

Also, checked in a profile I already had created and didn’t work there.

I’ll play with it and let you know. Thanks @Mattches and @289wk for the help! :smiley:

Can you try clearing cache for search.brave.com on your main profile and see if this does the trick?

  1. Visit the site
  2. Click the “lock icon” in the address bar
  3. Site settings --> Clear data
  4. Refresh the page and test again

Ugh, Scripts blocked in Shield settings. Clicked “allow all scripts once” in Shields and loaded. Such a simple thing. Going to just disable and allow all.

Thank-you!

Oh interesting, so you had your Shields settings configured to block all scripts?

Yes, I did and it prevents it from loading. If I open a new tab with it disabled, still displays. However, if I enable again, it removes the sub-menu.

Are you getting that?

Got it — and yes I can reproduce. Thank you for the info. Will pass this onto search team for review.

2 Likes