ProtonMail not loading in BRAVE


#1

Just reporting that ProtonMail isn’t loading in either a Private or Private TOR window.

Screen just displays “Loading ProtonMail…” indefinitely.

PM loaded without issue in Chrome.


#2

Yeah we had another user reporting the same thing not that long ago. I’m unable to reproduce this though - Protonmail loads and behaves as expected.

Is there anything unique about your setup or the way in which you produced this? Have you been able to login to Protonmail up until this point?


#3

Nothing unique about my setup or that I’ve done that I’m aware of.

Maybe ProtonMail objects to some of the privacy/encryption layers in Brave (Dev), though one would think that it, of all webmail apps, shouldn’t. (Or are those disabled by default in a Private window? I see that the Shields icon on that screen is the gray one.)

I hadn’t been using ProtonMail recently but it’s happening again right now. Screen just keeps displaying “Loading Protonmail…” – it never loads.

This is in a Private (not TOR) window in BRAVE Dev. on a Mac (Mojave).

Have now also checked using Private/Incognito windows in Safari and Chrome. No problem loading ProtonMail.


#4

@mk7z,
Still not sure why you’re unable access the site. Do you have Shields set to default settings or have you adjusted them (in Shields Defaults or for Protonmail itself)?

I’m able to visit, authenticate and load Protonmail using almost identical setup:


#5

I haven’t gone into Shields at all.

I mentioned that when I open a new Private window, Shields are off (icon is gray).

Is that the expected behavior?

It seems counter to my understanding of what one would want in a Private window.

Re the .gif, that spinning icon (an atom with its electron orbits, I guess?) is what I see, but the “Loading ProtonMail…” under it never goes away.

I don’t experience the problem in Safari or Chrome.


#6

:point_up: This is because when you open a Private window, you land on the “private window” screen which is not a “webpage”. You can also see this when you open a new tab in Brave (using default Brave NTP) - Shields are not active on static page displays like this and therefore will turn gray to signal that they are “inactive”.

Is the issue with Protonmail the same across all Brave installs you have on your machine?


#7

I’m assuming you mean the Shields aren’t needed in a Private tab/window?

In any event, it’s not something ProtonMail ought to object to, correct?

I had not been running any other version of Brave but just loaded the standard release to test (Version 0.60.45 Chromium: 72.0.3626.109 (Official Build) (64-bit).

Same thing. PM never loads.

image

Are you testing on a Mac running Mojave?


#8

Yes - PM works in all Brave installations as well.

Negative. Shields protect you while browsing websites in Private, regular or tor windows. But the new tab page:

Or the Private window “landing page”:

-are not websites and do not have a web address and come pre-packaged with Brave. Since they are not hosted, not websites, do not attempt to connect to an outside source, Shields are inactive on these pages (and any others like it - click the Rewards icon --> Rewards Settings and you’ll see that this page has the same result).

So the Shields icon here should have no effect on other sites while browsing.
Can you try clearing your cache/browsing data and try to login to your PM account again? [Menu] --> More Tools --> Clear browsing data


#9

OK, I see what you mean. Once a webpage is loaded the Shield turns back to orange.

I cleared all browsing data (since the beginning of time) in the standard release.

No change.


#10

Need more data on this if it’s still not working. Lets capture some:

  1. Visit Protonmail.com
  2. Open the Developer tools ([Menu] --> More Tools --> Developer Tools or CMD + option + I) and click on the Console tab:
  3. Attempt to authenticate
  4. After entering credentials and seeing the infinite loading symbol, you’ll see the Console start to display some data – Take a screenshot of this output and share it here

Let’s see what we can gather from this.


#11

FWIW, I have no problem logging into Protonmail with Private Window (non-Tor) and shields on in Brave Dev 0.62.11 Chromium: 73.0.3683.39 (Official Build) dev (64-bit) and Brave mainline 0.60.45 Chromium: 72.0.3626.109 (Official Build) (64-bit)on MacOS X Mojave 10.14.3.

However, in Brave Beta 0.61.36 Chromium: 73.0.3683.39 (Official Build) beta (64-bit) I got the “Aw snap, something went wrong” page after entering username and password.


#12

Thanks. All I’m seeing is this:

image

In the left column (the webpage area) I do at least see the login page, which I was never even getting to before. I entered my login credentials and got in normally.

I don’t know what opening the Console screen did (but you probably do).

Q for the future: How do I log in without having to open Console each time?


#13

@mk7z,

:point_up: It really didn’t do anything. Dev tools is a built in feature for web devs and curious folk to dig into what makes sites run. It shouldn’t have effected anything with respect to the issue.

You should not have to open the console in order to login to PM. If you logout right now, close/relaunch the browser, are you still getting the infinite loading screen?


#14

> If you logout right now, close/relaunch the browser, are you still getting the infinite loading screen?

Maybe I don’t have to. If I open up another New Tab (having logged out of ProtonMail in the first tab), ProtonMail now loads very quickly.

I’ll test close/relaunch later, to see whether it sticks.

If the console screen had no effect on the issue I don’t understand what got PM working once the console screen was displayed. Thanks, tho.


#15

I’m running development commit 1368a45 on my iPhone 7, iOS 12.1.4, built to device with Xcode. I can confirm logging into ProtonMail account successfully.


#16

Having that problem with ProtonMail not loading again.

Here’s what Console shows:

image

On the left side of the screen all that’s happening is this:

image

Where to next, Commandant (@Mattches)?


#17

I think this will require some more digging. I am still able to log into my Protonmail account without issue using macOS 10.14.3
We have an open issue for it but results seem to vary. Are you able to login using a Private window session?


#18

Thanks, it was the Private window where I had the problem, even with Shields off.

When I tried later in a standard window I was able to log in.


#19

This is still happening in a Private (non-TOR) window.

ProtonMail never loads.

In fact I’ve just discovered that it’s not loading in a regular window either.

No difference. Just this (never-endingly):

image

Few minutes later… no problem opening ProtonMail in Safari.


#20

That’s really weird. I just successfully logged in using 0.61.51 Chromium: 73.0.3683.75 (Official Build) (64-bit), Beta 0.62.25 Chromium: 73.0.3683.67 (Official Build) beta (64-bit), and in Dev 0.63.18 Chromium: 73.0.3683.75 (Official Build) dev (64-bit), shields on and all, in MacOS 10.14.3. What is the current version of Brave you’re using?

Edit 20min. on: Forgot to mention was using non-Tor private windows.