Protected Content doesn't stream when allowed per site, only when allowed globally

Description of the issue:
Netflix and Spotify give their respective ‘protected content needs to be enabled’ error pages.

How can this issue be reproduced?

  1. brave://settings/content/protectedContent default behavior set to ‘don’t allow’
  2. Netflix / Spotify site specific settings set to allow
  3. Attempt to play protected content

Expected result:
Protected content plays.

Brave Version( check About Brave):
Version 1.39.122 Chromium: 102.0.5005.115 (Official Build) (64-bit)

Additional Information:
When protected content is allowed globally protected content plays as expected.

Also Attempted
reinstalling Widevine


Brave Browser for desktop / laptop computers . . .

There is no site-specific setting for Protected Content (protected by copyright).

Nothing at:

  • brave://settings/content/protectedContent
  • brave://settings/extensions
  • brave://settings/shields

And nothing in the site-specific Shields (Lion) icon panel settings.


There is a section at the bottom that says:

Customized behaviors

Sites listed below follow a custom setting

and then there is a couple of add buttons that let you make exceptions per site

They can also be accessed by clicking the ‘lock’ icon in front of the https on the address bar


Thank you. That setting is a puzzle, because it does not seem to be ‘site-specific’ - for example, if you go to:

  • brave://settings/content/siteDetails?

you will find that


is not in the site-specific list.

Also, I am using Brave Browser for Mac, and there is no ‘Customized behaviors’ section.

Going here I can see it in the list

it says windows on the post


Mac: First site-specific item is ‘Autoplay’ - not shown in the following:

Thanks for your screenshots. I have not previously had any information, that there would be such a difference in the appearance of the site-specific settings.

@Chocoholic - you probably would like to know about the differences in appearance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.