Problems with twitch on Brave

Hi, I also had the same problem, I had to disable all the “shield” protections temporarily to connect, then after I could put everything back to normal.

1 Like

Responded to the similar thread here;

2 Likes

I can confirm this, in beta and Stable.
New profiles: same issue.

2 Likes

I have tried Disabling all settings on the shields page, resetting site-specific permissions, enabling EVERYTHING relating to cookies, popups, redirects, etc. and still cannot get to the 2FA.
I saw the gif in the other thread, is that the current version? I cannot reproduce that behavior.

EDIT*
Since it will not let me add a new reply to this thread as I am new here, here are the screenshots of my attempt to follow the latest instructions of clearing my cookies, ensuring aggressive fingerprinting is off, and re-logging in. Still same result.

2 Likes

why did they delete the reddit thread?

I can’t create clips, just goes to about:blank

I can’t follow streams or add users to block list

and it no longer remembers my previous position in VODS I’ve watched

I have shields disabled and twitch fingerprinting allowed

problem on regular and Beta, nightly seems to work normal

Just clear all the cookies for twitch.tv, And ensure Aggresive fingerprinting isn’t enabled on twitch. Then refresh and relogin.

It still doesn’t work, I’ll wait for the brave to update because that’s the problem with the update [
Versión 1.43.93

1 Like

I have no shields enable, no blocking in any way active.

The login request shows with a error in the console:
POST https://passport.twitch.tv/integrity 400 (Bad Request)

After a little search, appears that this happens also to other users in different browsers:

Maybe not related with brave only

3 Likes

Thanks for the feedback, good to see its not a Brave specific issue @djprmf

1 Like

It seems to happen when you disable the Brave Shield and visit Twitch with no cookies.

It still happens in the latest nightly build.

How to reproduce:

  1. Go to Twitch.tv
  2. Disable the Brave Shield
  3. Clear your cookies
  4. Restart Brave
  5. Try to login again (the error should now appear)

Here is a video how I tested it: https://i.imgur.com/WZITKhU.mp4

Not sure if you didn’t just read the previous post, not related to Brave.

1 Like

i think twitch is blocking brave users from login to twitch, twitch French support department told us to switch browsers.

1 Like

I’ve been using Nightly build the last few days without issue. The issue persists on beta and current versions

1 Like
2 Likes

Twitch does not work at all on Brave for me on my Mac

I was able to login into twitch on my mobile brave browser but I haven’t been able to find a way to do so on my PC.

Same issues, also on Nightly… following:]

Does anyone know when this ‘issue’ will be resolved ?

Be patient my English. It’s super broken.

In my environment, problem cause is random-user-agent extension.
The only way to solve is not “Enabled on this domain” off, just disable or pause extension.

*Shields : on → ok / off → NG
*Trackers & ads blocking : Standard/Aggressive/Disabled → ok
*Block fingerprinting : Standard → ok / Disabled → NG

I’m using stable,beta,nightly and I’m in same trouble this several days.
So I tried some touble shooting method(disable all extensions, clear cookies, etc) but not resolved.
And then I tried guest mode, login error has gone. I saw login code check popup. I didn’t know the reason why.

30min ago, I thought I wonder hidden parameter or env info makes error, and then I disabled extensions one by one.
And now, I reached answer.
I don’t know the reason why keep error when I disable all extension at once but to solve problem is to disable random-user-agent extension only.

my recommend method
1.Shields is on, Trackers & ads blocking is anything fine, Block fingerprinting is Standard.
2.pause or disable random-user-agent extension
**of course if you don’t have this ext, needless to do so
3.clear all twitch cookies
4.avoid cache and reload twitch page (hard reload)
5.login

if you have random-user-agent extension, try it. :wink:

1 Like