Problems transferring Brave configuration from old HDD


#1

I did a clean install of Linux Mint 18.3 on new (to me) hardware, then connected the previous HDD to that PC in a USB dock. Both OSes are 64-bit Mint 18.3. So I have the entirety of the old OS’s files available. I installed Brave on the new hardware using ‘wget -O’ to download the brave.deb file, then ran ‘sudo dpkg -i’ on it.

I fired up the new Brave install to confirm it worked as expected, then I closed it and copied everything in the old ~/.config/brave directory into the new. Which I thought was the approved method for a “heavy” backup.

Only it didn’t start. Initially I got a spinner for a few seconds, then …nothing. I checked ‘dmesg’ and didn’t find anything relevant and confirmed no brave process was running.

I don’t know for certain they are the same version of Brave, however, I did have auto-update enabled, and I ran the brave browser on the other hard drive (in different hardware) as recently as yesterday.

I note that the instructions on this web site mention using ‘~/.config/brave/`session-store-1’ for light backups but neither of my installs has a ‘session-store-1’ directory (or ‘session-store’ by any number).

What I’m trying to recover is settings, bookmarks, passwords, …the whole enchilada.


#2

Do you have the install via snap or directly installed from a deb file?


#3

Both. I’ve tried it both ways.


#4

Okay, here’s me looking sheepish.

I rebooted and it’s fixed. Unlike that “off-brand” OS, I reboot Linux so infrequently that I sometimes forget that the act does on occasion have diagnostic benefit. This was only the second reboot since the initial install.
Bookmarks, passwords, everything is there.


#5

Glad that everything is sorted out. Just in case you use snap build the path will be different.


#6

#7

#8

Okay, it’s not so fixed. And I did something really, really stupid.

I left the USB dock with the old HDD plugged in through a reboot, and Ieft USB HDD ahead of internal HDD in the BIOS boot order.

You can probably see where this is going. When I thought it was fixed, the OS on the internal HDD wasn’t the one that was running, the old OS on the external HDD was (I’m actually amazed it adapted to the new hardware with no evident problems) So it wasn’t fixed, I was just running the wrong OS. When I unplugged the dock and rebooted, it was back to no bookmarks or passwords.

At this point I have installed the browser using dpkg, gdebi and snap and all three have shown the same problem. I also found a tarball with a backup of the entire brave directory that I had created this past February when I updated the OS on the old hardware from Mint 18.1 to 18.3.

That tarball worked. I did a clean install to 18.3 and used the tarball to transfer the ~/.config/brave files from the Mint 18.1 install to the 18.3 install and it worked. However, if I do that now, the browser will not start. I get the spinner for a few seconds, then nothing.

And I still have the hard drive I used on the other box, and when I copy all the files from ~/.config/brave on it into the new install, same result. I don’t even get a spinner.

This is no longer about this particular install, I’ve already written this one off and conceded I’ll have to start from scratch. But what I don’t want to have to do is start from scratch the next time I update the OS, so I’d like to know specifically which files and folders the bookmarks and passwords are stored in. Because if I limit the number of files and folders I’m transferring to the ones I know are needed, I’m also reducing the possibility that I’m moving the files/folders that are the source of the problem.

Bonus points for figuring out why a set of backup files that worked fine on the same OS on different hardware three months ago won’t work now.