Problems installing Brave on a Windows 7 Ultimate laptop


#1

I have been trying to install the latest version of Brave on a Windows 7 Ultimate machine (AMD X64 2 core 2.7GHz). I installed .Net 4.5.2 (I hope that was OK as it asked for version 4.5), restarted the machine and when I tried installing Brave it came up with an error message -:

There was an error while installing the application.
Check the setup log for more information and contact the author.

What is the problem???

Log file is too big to post.


#2

Hi @judgedredd, thanks for reaching out.
I actually just worked on this same issue with another user. We ended up helping them individually (that is, the “solution” is not posted in the thread linked) and if your situation is the same as his I’d like to officially open an issue on this subject. But lets try a few workarounds first to see if we can get this up and running. Try the following:

  • Close any Brave processes and log out of your Windows profile (you can also restart, up to you)
  • Log back in, navigate to the installer, right click and "Run as Administrator
  • Allow installer to finish, then open Brave and try again

If that doesn’t work:

  • In the windows search bar, type %AppData% and open the folder
  • Inside you should see your Brave folder. Right click and rename this folder (anything will do, maybe rename it to “Brave2” or something easy to remember/identify)
  • Repeat the steps in the above suggestion

If nether of these methods work, please reply back and I"ll be happy to continue troubleshooting with you.

Thanks :slight_smile:


#3

Hi,

Thanks for getting back to me. I tried both ways and it still would not install. Same error message came up as in the original time this happened. On the third try I even went into the Brave folder (inside the AppData folder) and double-clicked on the update file and created a Squirrel Update file. Still no joy. This is the only program I have ever encountered this problem with.


#4

@judgedredd, just want to make sure. :slightly_smiling_face:

  • From where you download Brave?
  • And are you sure you’re installing the 64-bit version of Brave and not the 32-bit?

#5

Hi eljuno,

I downloaded Brave from the Brave website. I did download the 64bit version as it had the number 64 in the file name - BraveSetup-x64.


#6

I haven’t got anywhere with this after following the procedures you outlined and there has been no response from anyone after my last post. Is there anyone interested in helping me or not?


#7

Sorry for the late response!
First, can you show us the setup log? You can take a few screenshots of it if it’s too big to post in one message but it would definitely help us figure out whats going on.
The I’d like you to try the following:

  1. Type “MsConfig” in Start Search to start System Configuration, then go to Tools tab, select Change UAC Settings, then click on Launch button.
  2. Click on User Account Control settings link.
  3. Slide the slider bar to the lowest value with description Never notify.
  4. Click OK to make the change effective.
  5. Restart the computer to turn off User Access Control.

After that, try and install Brave again. If not please let me know :slight_smile:


#8

Ok. That worked. Wow! Never been through so much hassle to install a program. Thanks for getting me through it!!

My question is though, why did I have to go through so much trouble???


#9

Close any Brave processes and log out of your Windows profile (you can also restart, up to you)
Log back in, navigate to the installer, right click and "Run as Administrator.
Allow installer to finish, then open Brave and try again


https://www.minimilitia.mobi/ https://www.applock.ooo/ https://www.7zip.vip/


#10

Hi shelbyomi,

Everything works now, but thanks for your response.


#11

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.