Problem when allowing a cookie when "Only block cross-site cookies" is selected

Description of the issue:
When trying to allow a certain cookie to be used, it is indeed added to brave://settings/content/cookies , but it doesn’t work.

How can this issue be reproduced?
Hope this is reproducible:

  1. Check if “Only block cross-site cookies” is selected under brave://settings/shields
  2. Try allowing one blocked cookie by clicking on the lock icon (on the url bar)
  3. Refresh the page as requested
  4. Check if the cookie is allowed (it’s blocked for me) by clicking on the lock icon again
  5. Verify that on brave://settings/content/cookies the url is there under “allowed”

Expected result:
It shouldn’t block it after I manually allow it, right?

Brave Version( check About Brave):
Version 0.68.132 Chromium: 76.0.3809.132 (Official Build) (64-bit)

Additional Information:
The syntax that is used on brave://settings/content/cookies is, for example: [*.]google.com
The reason why I would like it to be working is because of an extension that uses a “cross-site cookie”.
The workaround for me is to disable “Only block cross-site cookies” which is not the ideal.