Private Browser crashes Brave

Description of the issue:
Upon opening a private window and searching something, Brave crashes.
Steps to Reproduce (add as many as necessary):

  1. Open a new Private Window
  2. Search for something or enter a URL

Actual Result (gifs and screenshots are welcome!):
Brave crashes, and the page hangs.
Expected result:
Webpage should be displayed without crashing
Reproduces how often:
Always when opening a Private Window
Brave Version(about:brave):
Version 0.66.99 Chromium: 75.0.3770.100 (Official Build) (64-bit) < Current latest version
Reproducible on current live release (yes/no):
Yes (for me).
Additional Information:
I am on MacOS Catalina beta, however the issue was present when I was on Mojave too.
Quitting Brave doesn’t work. Force Quit sometimes works but mostly MacOS reports Brave as quitted but the page window is still there in a crashed state. Eventually it disappears, however when I tried to re-open Brave it failed to launch. A reboot allows me to relaunch it but the issue persists.

Same version of Brave on MacOS 10.14.5 works fine with Google as default search engine (yeah, I have to fix that).

Same question after switching to DuckDuckGo and deleting Google, then relaunching:

Both of those were Private Windows spawned using the File menu in the macOS menu bar, so I tried spawning a post-Google-deletion Private Window from the hamburger menu in the upper right corner of the window with same result. Successfully a URL in both, too.

Do you have other extensions running? That doesn’t seem like the most likely issue to me, though. @Mattches, any ideas?

For comparison, here are my settings in Shields (Global) and Privacy and Security:
image

@ZincXX,
As @hnktong mentions, I would wager there may be some extension enabled causing trouble – can you try with any installed extensions disabled?