Print dialog not showing my installed printer in Windows 10

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting


Description of the issue:
When using Brave, type Cntrl-P or choose Print from the menu and a dialog shows up that only shows “Save as PDF” as the destination. Choosing “See more…” doesn’t show anything that can be selected. This started happening a couple months ago.

This problem DOES NOT happen with Chrome or with FireFox. Both of these show my installed network printer and also allow me to select the “system” print dialog. Brave does not.
How can this issue be reproduced?

1.Open Brave - go to Google.com
2.Type Cntrl-P
3.Try to select the installed printer rather than Print to PDF - nothing shows up to select.

Expected result:
Cntrl-P should bring up my default Windows 10 system printer

Brave Version( check About Brave):
Version 1.28.105 Chromium: 92.0.4515.131 (Official Build) (64-bit)

Additional Information:
Latest version of Chrome and Firefox both print perfectly. I have tried clearing the cache and have reinstalled the printer from the Windows 10 Print and Fax manager. No change.

Does the issue disappear when you allow fingerprinting via the Brave Shields icon in the address bar?

I think it could be related to the Github issue below.

Is what you are trying to see, located here- Windows settings > Devices > Printers & scanners?

This has nothing to do with Google sheets. I can print to my network printer from Chrome, Firefox and Edge. They all see my printer. Only Brave is not showing my network printer.

Yes, the network printer is clearly visible as the default printer in the printers & scanners windows setting.

I have also tried deleting Brave and reinstalling. No change.

I didn’t say it’s an issue with Google Sheets, it obviously has something to do with Brave since other browsers work fine. Just linked an open Github ticket that describes a similar (same) issue.

Sorry, don’t see any link.

https://github.com/brave/brave-browser/issues/11913

I’ll ask you one last time to check whether disabling the fingerprinting protection of Brave Shields via the icon in the address bar allows you to print.

No. Allowing all fingerprinting had no effect. I also tried disabling ALL shields, with no effect.

So, now that I provided you with “one last time” answer, no comment?

You make it sound like as if you made me a favor. I asked you a couple of times to check something, which you initially ignored, so I had to check whether you’re willing to help me assist you or not. Like I wrote in the very beginning, I think your issue could be the same as the one reported by @Mattches. If I’m correct, I can’t help you because developers are the ones who have to commit a fix.

I should have communicated back to you more clearly. I thought this forum is for developers. Do I need to comment someplace else? Please accept my apology.

It’s all good.

Let @Mattches take a look at your thread, he is part of the Support Team.

Otherwise, the place to communicate with developers is Github.

The last thing I could suggest before @Mattches takes over, is checking whether your issue persists in a fresh user profile. That’s just for testing purposes, not suggesting giving up on your current user profile.

@ronsonntag,
Can you please test the behavior with a new profile as advised by @Rethanis?

New profile works. Now, how do I get my normal profile to work?

@ronsonntag,
So what we’ve done here is isolated the issue a bit to something(s) in your original profile. It is very likely ether an issue with some extension you have installed or a caching issue. To check both:

  1. If you have any extensions installed, try disabling them and test to see if your printer appears while they are. You can then re-enable them one at a time and root out the offending extension.
  2. If you don’t have any extensions installed and/or the issue persists when the extensions are disabled, I would try clearing your cache/browsing data (probably for All time range) and then test again to see if your printer appears.

Tried both options, no change. But, in addition, the profile that I created now no longer has my printer listed. I also tried creating another profile but it too does not show my printer. I’ve tried creating a new profile several times now and I cannot get the printer to show up.

The other thing I notice is that Chrome, Firefox, and Edge all give me an option, at the bottom of the printer selection dialog, to “Print using the system dialog…” Brave is the only browser that is not giving me that option.

This issue is also happening for me: no option to print to printer, it defaults to ‘Save as PDF’, and there’s no option to modify.

I’m printing from Google sheets
I have no extensions installed
I have MacOS Catalina

@Dark_Mattches Are you on this? Haven’t heard anything from you yet.