Previous Rewards have worked in USA, now: Ads are not yet available in your region. and no balance

Briefly describe your issue:
I am in USA and have had brave rewards working and linked to gemini for a long time - suddenly it tells me ads aren’t available
What Operating System and Brave version are you using (Menu --> About Brave)?
Mac OS Montery - Brave v1.43.89
Is your browser wallet currently verified? (yes/no)
What date did you verify your wallet?
long time ago
Have you been able to successfully receive payments in the past?
Are you using a VPN? (yes/no)
Are you in a supported region (see here for list of supported regions)?
Does your device pass the SafteyNet check (Android only)?

Have you manually turned off Auto-contribute on all of your devices linked to Uphold??

Could you send a screenshot?

Are you sure you aren’t using a VPN?
If yes, then also try to click verify and see if it says account flagged.
If it doesn’t then you’ll probably have to raise a ticket.
You can raise one here. →

Yes. No vpn is being used

Okay, do let us know if your account is flagged by trying to verify with Uphold/Gemini.

@JRP1 Let me ask a few things here.

  1. Do you use anything like a proxy server? I know you said no VPN, but trying to figure out if you use anything which can hide/mask your IP.

  2. Your device has its Locale completely for the United States, right? When I’m seeing that image it kind of makes it seem a bit like what I’d see on a browser belonging to a country that can’t participate in Rewards. There’s no on/off toggle for Brave Ads and all.

  3. Could you to go brave://rewards-internals and then click on the Ad diagnostics tab. There will be a line that says Locale:. Can you tell me what it says there?

  4. (probably should just tell you to try this first, but I am curious about the first three). Try to reinstall the latest update and see if it fixes things. DO NOT UNINSTALL, leave things as it, just download and apply. If there’s any errors on yours, it should fix it. (I said don’t uninstall because I don’t want to have you lose any information). You can get latest update by going to

No I have verified with Gemini - have transferred brave into gemini previously - can still access my gemini account…

No proxy, no VPN in use.
US local

Enabled: true

Locale: en-US

Already on that version

I know you are on that version. I’m saying if we pretend something went wrong with the download, if you install again on top of it, should repair. It seems silly but has solved things before. If you don’t feel like doing it, that’s fine.

This is definitely one of the things I was curious about, thought maybe an issue there.

I’m going to tag @SaltyBanana and @Evan123 over here to see if one of them can guide you through. I mean, yours is an odd circumstance I don’t see much. And I’m about to have to do something, so not taking the time to search through right now to see if any similar has been asked and answered in the past. I may come back to this later, but leaving this here and hoping they might come in and respond in the meanwhile with an answer.

I see - I downloaded and reinstalled… Fixed it!
Thank you!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.