Pool.pm broken. Please fix

Description of the issue:
The website https://pool.pm/ doesn’t work properly on the Brave I have installed in my laptop. Most of the time it just keeps loading (the rotating cardano logo). Sometimes It manages to display something only after I refresh the site. All shields down globally.
Exact URL of the website in question:
Did the issue present with default Shields settings? (yes/no)
The sites doesn’t work properly with default shield settings and with deactivated shields.

Does the site function as expected when Shields are turned off?
Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
Don’t know.
Does the site work as expected when using Chrome?
Brave version (check About Brave):
Versión 1.30.87 Chromium: 94.0.4606.71 (Build oficial) (64 bits)

I must also say that the site used to work on my PC’s Brave browser but my PC broke and I’m now on my Laptop. But I remember I had to change some configurations on my PC’s Brave to make some other sites work properly so maybe that made pool.pm work too, but I don’t remember what changes I made on my PC so I can try it on my laptop.

Please, help me with this, I need to use this site quite often.

EDIT: When opening the site from the links I posted above it loads properly but when I try to use any of the buttons to the right that’s when it fails. For example, if I click on the search button the url changes in the url bar but it doesn’t go there, I have to refresh the site for it to load the search interface, then here if you paste any Cardano wallet it should automatycally display the contents of that wallet but it does nothing. It’s similar with the NFT button, I have to refresh the site after clicking on it for it to display the NFT interface and then it just keeps loading until I refresh again and it shows what it should (sometimes it doesn’t).

Hello, anybody from the team?

The site loaded fine, animations worked the same in Brave and Chrome.

Thanks for the reply, it made me realize that the problem was local to my laptop’s brave. I just tried it on incognito mode and it works flawlessly, so i went in a hunt for an extension as the culprit and i found it. It was translation extension that, for some reason (is just a right click and translate kind of extension, not an “always translate site” one), caused the site to malfunction. Can’t give the url of the extension on the webstore cause i can’t find it but the name is “Traductor”. So yeah, sorry about that, can’t believe it didn’t occured to me to try this first.

Great to hear its working! Thanks for the update

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.