PNG file attachment in Gmail not always opening Win10

In Gmail when file attachment with PNG extension is clicked, Brave switches to view window and the file can be viewed BUT sometimes all you see is a circle going around and around.

If you close the view window and try again, same result.

I have found that while the circle is showing you click on the 3 Dots and select “Details” the file is opened for viewing.

If Gmail is opened in chrome this problem does not happen.

Version 1.48.158 Chromium: 110.0.5481.77 (Official Build) (64-bit)

1 Like

Hello there @alatel please accept my apologies for this inconvenience.

Try disabling Hardware Acceleration in settings to see if this resolves the issue. You’ll find this in brave://settings/system > Use hardware acceleration when available > toggle off > relaunch Brave.

Let me know if that works.

Hi Kevin

Done as you suggested and it seems to have had the required result.

I tried clicking on the PNG attachment 30 times and it opened every time.

Thank you for your assistance.


1 Like

@alatel hi again, glad to know that!

If you have any other comments or concerns please let me know in order to further assist you.

Regards :lion:

Hi Kevin

Its started doing it again intermittently (also happens with JPG files)


1 Like

@alatel could you please try opening your main profile in private or guest mode to see if the issue persist? If it doesn’t, try disabling your extensions to see if this is the cause of the issue.

You can open a Guest Window by going to Main menuOpen Guest window:

  1. On your computer, open Brave.
  2. At the top right, click MenuMore toolsExtensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let me know if that works.

Hi Kevin

Disabling extensions makes no difference still intermittent and clicking details opens file

Opening New or Guest window makes no difference still intermittent and clicking details opens file


1 Like

@alatel did you try disabling your extensions (if you have any)? If you don’t have any extensions, go to your shields and make sure that Upgrade connections to HTTPS and Block scripts are disabled.

Hi Kevin

Yes I tried disabling extensions but it didn’t make any difference.

“Block Scripts” were disabled, “Upgrade connections to HTTPS” was active BUT disabling did not make any difference.

After disabling, testing with PNG file, the file opened every time for about 5 minutes the problem started again not opening more often than opening (clicking on details would still open file)

Should “Upgrade connections to HTTPS” remain switched off or should I switch it back on?

1 Like


Turn it on again as this was not interfering with your issue. Do you have hardware still off on your Browser?

Please try installing the Beta or Nightly version of Brave to see if the issue persists on those versions.

Hi Kevin

I have turned “Upgrade connections to HTTPS” and “Hardware acceleration” on again.

I downloaded and installed the “Beta” version of Brave as suggested. On testing opening PNG or JPG files it happened mainly without any problem.
I say mainly because occasionally I needed to click on the file to be opeded twice as the file did not open on the first click.

Brave “Beta” installed a completely fresh installation of Brave and did not give me any option of importing Bookmarks and settings from the original Brave installation. (should this be reported separately


@alatel are you able to go to main menucreate a new profile to see if you are prompted to import your bookmarks and browsing information?

Be waiting for your response.

In the release version or the Beta version?

Tried “creating new profile” in both versions and there was NO option to import anything

Beta is working as expected — it will not offer to import settings from other Brave installations (I do believe we plan to add this functionality down the road). I’m not entirely sure what is causing this behavior, especially if its happening in Beta as well — can you confirm that you see the same behavior in the Beta browser?

If so, can you please try disabling Shields entirely (on either installation) and seeing if the results are the same?

Sorry, my mistake, when you “Create a new profile” in either installation the bookmark bar has an option to import bookmarks from any browser installed except Brave.

I’m aware — as I said this is expected. Can you answer my previous questions regarding the behavior you see in gmail?

Resulrs are exactly the same with Shields entirely disabled

Thank you. Not quite sure what is causing this, will have to reach out to the team for additional information on this.

Appreciate your patience.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.