| Site was updated; only MiniPlayer with custom Rule

Description of the issue:


I hope I found the right channel for this post!

The german televison broadcaster “RTL” updated it’s online streaming service. The new setup is circumventing the ad blocker, which worked well the past few months, and shows 5 minutes of Ads every 10 minutes. (i.e. 5 min Ads, 10 min your Video, 5 min Ads, 10 min your Video. Once in a while you get 10 min of ads).

However, I found that adding the following filter rule stops any Video Ads and goes straight to playing the expected stream:


With this filter, audio does work; no video is displayed.
Using the mini player everything, including video, works, so the data is there.

I’ve done some research. The frontend is written in Angular and - probably - uses the player component provided by bitmovin.

Sadly, I do not have enough experience in “frontend hacking” / injecting JS, to fix this issue, otherwise this would’ve been a PR. :slight_smile:

Exact URL of the website in question:

The streaming provider in question can be found here.

A video by the streaming website, which I tried to watch when this happened, can be found here.

Screenshot of the ad as it appears in Brave

Did the issue present with default Shields settings? (yes/no)


  • Ads with default shields

  • With custom filter: no video unless viewing in miniplayer.

Does the site function as expected when Shields are turned off?

Yes, although with 5 minutes of ads every 10 minutes.

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):

Yes, adding ssl.* to the content filters, causes the stream to only work properly within the miniplayer.

Does the site work as expected when using Chrome?

Yes, although with 5 minutes of ads every 10 minutes.

Brave version (check About Brave):

Version 1.57.49 Chromium: 116.0.5845.96 (Official Build) (64-bit)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.