Please ! fix Google translate

Google Translate doesn’t work, please fix it, need a feature like Google Chrome to automatically translate web pages, thanks

Please edit your post and provide the requisite info. Like Brave version, OS, example sites, screenshot of the issue, etc.

This kind of info should be provided when you try to create a new thread. Providing more info will really help with support and troubleshooting.


1 Like

What @eljuno says. However, I needed a break, so I tried a few things in Brave main release 0.60.47 Chromium: 72.0.3626.119 (Official Build) (64-bit) MacOS 10.14.3 and Windows 10 10.0.17763 Build 17763, and in Brave Dev 0.62.16 Chromium: 73.0.3683.39 (Official Build) dev (64-bit) MacOS 10.14.3, all with Shields On. Plain old translation works fine in all of those, but I don’t think that’s what @bUser means.

What I gather from @bUser is that he/she is trying to use the Translate web page to then translate a foreign language web site. For example, I tried doing that by going to, setting translate from Spanish to English, typing Univisión’s address, and clicking the resulting link. In all three browsers, the English pops up briefly, but is then replaced with the original text thus:

Same thing happens with Shields Off no matter what language I specify for it to translate to, so I confirm @bUser’s issue. I’m guessing it’s because it’s Google as a third party, but my KungFu is weak in this regard.

As a workaround, installing the Google Translate extension gets around the issue. Yes, you have to click a button or two when you get to the website you want translated, and God only knows what the extension is really reporting home, but it works without turning shields off and probably is no worse than turning Shields Off [[same idea re. Google Extensions Use hopefully to be discussed at Using GOOGLE Extensions & privacy]].

Same behavior in Brave 0.60.47 Chromium: 72.0.3626.119 (Official Build) (64-bit) on Linux Mint 19 Cinnamon 3.8.9 64-bit (based on Ubuntu bionic) kernel version 4.15.0-45, extension provides workaround.

Same behavior in iOS Brave 1.8 ( on iPhone 7 running iOS 12.2 (should be beta). Extension not available for iOS version of Brave as far as I can tell.

Version 0.60.48 Chromium: 72.0.3626.121 (Official Build) (64-bit)

Hi there
Version 0.60.48 Chromium: 72.0.3626.121 (Official Build) (64-bit) OS win10 Home V1803 Build 17134.590
Attempting to open Japanese websites (eg and absolutely nothing happens when I right click the page and select Translate to English.
I have the same extension installed on Slimjet and its working perfectly for that website…

Have the same isue…
Iam using
Version 0.61.52 Chromium: 73.0.3683.86 (Official Build) (64-bit)
linux mint 19.1 Mate 1.20.1

This is slightly different than what the OP appeared to suggest, but I’m guessing that the contextual menu option is hitting up Google Translate for the translation and that’s why it just sits there (for me, too, in Brave-Dev √0.64.30 Chromium: 73.0.3683.75 (Official Build) dev (64-bit) on MacOS 10.14.3). So, behavior repeated here, @Mattches @eljuno.

@Baltadon, the Google Translate extension workaround I posted above should get what you want done in the meantime. Here’s the link to the Google Translate extension .

Thanks @hnktong, Using the extension and selecting “Translate this page” works for me now.

1 Like

It would be great if there was a choice in the settings to select translation services, right now it seems Brave uses microsoft translate, which is not as good as google translate.


I’m also often getting this error


Could this by any chance be related that I have used this and it blocked some MS ips?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.