Pixiv loading and saving issues


#1

For some reason when I try to save/load images from Pixiv.net, I either get a 503: Forbiddon or the download is interrupted.


#2

Per the posting guidelines please provide the requisite info so we can investigate in an efficient manner.

Thanks!


#3

Windows 10


Brave Version 0.19.80


#4

I’ve been looking into this, since I have visited the same website in the past. I have replicated this problem on Antergos Linux, running Brave 0.19.53. It happens when shields are up or down. I updated to 0.19.80 and tried again. The download failed with Interrupted status. However, with 0.19.80, it did not show the downloads bar at the bottom of the window. It failed silently.

The chromium developer console does not show any network errors when attempting to download. I have not found anything in the muon code that sets a downloadItem’s status to INTERRUPTED. I’m not a C developer, so I’ll have to do some digging to see if I can find something that will tell me WHY it was interrupted. However, I will keep looking into this.


#5

I got the build running locally and am looking into the details.

I have been using this work for some diagnosing. I notice when I right click > Save Image, then click “Save” at the prompt, it fails silently. This does not happen in Chrome – IF I am logged in to the site. One thing I notice is that if I log out of Pixiv and try to access the direct URL for the image in Chrome then their Nginx replies 403 forbidden. The same happens when I run wget on the URL.

There must be some authorized context that does not get transferred when you finally click that “Save” button in the pop-up dialog. I say this because if I am logged in and right click the image > Open Image in New Tab, then I can see the image on the i.piximg.net server. However, when I then right click > Save Image it still fails silently. When I start Brave using npm run start-log I do not see any errors on the command line when I try saving the image. I also see nothing in the console in the browser. I will continue looking in to this to see if I can find somewhere that it is failing silently.


#6

I’ve been digging into this, but can’t find the root cause yet. I’m very unfamiliar with C development, and the problem seems to be occurring at that level. I’m going to have to pause on this for now, and not make any guarantees about a date for a solution. Sorry :frowning: