Phishing website - domain rerouting - please help

When I enter “Coinbase.com” I get redirected to https://interstellar.cm/stargate-enterprise/
What can I do to remove this domain forwarding.
Thanks

Well that’s certainly strange. Do you get this behavior when you try to visit Coinbase in a Private window as well?

Might be malware.

Download Malwarebytes and scan your PC, if on android try Kaspersky, Bitdefender, Hypatia.

No malware was detected. I cleared the entire browser history, deleted all cookies and now it works fine

Hi

@Difi Try this

  1. Make sure Upgrade connections to HTTPS is enabled @ brave://settings/shields
  2. Try opening the page from here: https://www.coinbase.com/
  3. Open Brave, then hold the keys CTRL+SHIFT+N, paste the url https://www.coinbase.com/ then open the page. Result?

I tried this yesterday and this worked right away.
Everything in a private browser worked without problems

@Difi Have you installed an extension recently?
Disable all your extensions an open coinbase normally.