'Pending' YouTube video will start playing in the background if another tab is moved

#1

Description of the issue:
If you have 3 tabs open and the first is in focus and the second is a ‘pending’ YouTube video, if you move the third tab out into a new/different Brave window, the YouTube video on the second tab will start playing even though focus remains on the first tab.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Open Brave and go to YouTube
  2. Open two videos in background tabs by Ctrl/Cmd+clicking on them. Neither video should autoplay.
  3. (Optional, but good to avoid a cacophony) Go to the third tab, the video will start playing. Pause it and return to the first tab.
  4. Now, while on the first tab, drag the third tab out of the Brave window and into its own new window (don’t click it into focus first - focus should remain on the first tab).

Actual Result (gifs and screenshots are welcome!):
Immediately, the second tab video starts playing in the background but the first tab is still the one in focus in the window.
I’ve temporarily uploaded a video showing it here

Expected result:
Either the focus should change to the second tab or the YouTube video in the second tab shouldn’t auto-play. Either makes sense.

Reproduces how often:
Every time

Brave Version(See the About Brave page in the main menu):
Version 0.63.35 Chromium: 74.0.3729.61 (Officiel version) beta (64-bit)

Reproducible on current live release (yes/no):

Additional Information:

1 Like