PDFs not displaying in Brave

Description of the issue:
Opening PDFs in Brave causes the file to look corrupted, rendering it unreadable. Downloading the PDF shows no corruption to the file.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Have closed and re-opened Brave a few times, and tried with a variety of PDF links.

Actual Result (gifs and screenshots are welcome!):
None are displaying properly. E.g.

Expected result:
I’d expect the PDF to be legible and display properly.

Reproduces how often:
Every time

Operating System and Brave Version(See the About Brave page in the main menu):
Version 0.65.118 Chromium: 75.0.3770.80 (Official Build) (64-bit)

Additional Information:
I’m running Parallels on a Mac. The Mac version of Brave has no issues with PDFs, and other browsers on my Parallels desktop also have no issues with PDFs.

@ana135 Thanks for reporting. would you mind sharing the PDF link which is not displaying in brave? So that I can try from my end.


Hi, thanks and apologies for the delayed reply. It’s been happening with literally every PDF I tried to open, so it doesn’t matter what link you use. The one I used for the screenshot is shown in the screenshot at the top - it’s https://www.unocha.org/sites/unocha/files/GHO2019.pdf

This topic was automatically closed after 30 days. New replies are no longer allowed.