PDF's Downloading when they should display


#1

This problem appears on both my Linux Ubuntu 16.04 LTS:

Brave 0.22.669
V8 6.6.346.24
rev 6cda2e8
Muon 5.2.7
OS Release 4.13.0-41-generic
Update Channel Release
OS Architecture x64
OS Platform Linux
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 66.0.3359.117

And on a Windows 10 system running latest OS release:

Brave 0.22.714
V8 6.6.346.26
rev fa2fbca
Muon 6.0.9
OS Release 10.0.16299
Update Channel Release
OS Architecture x64
OS Platform Microsoft Windows
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 66.0.3359.139

When a web application sends a PDF for embedded display, using the correct MIME type, Chrome, Chromium, Firefox and Edge all display it. Brave immediately downloads and does not display.


#2

This typically happens if the PDFViewer extension is not enabled. Double check to see if PDFViewer in about:preferences#extensions is enabled.

I toggled PDFViewer on and off yesterday to experiment with another issue, and the behavior went from opening inside the browser to prompting for download, as you described.


#3

Unfortunately that does not seem to be the source of the problem. I had already tried toggling the PDFViewer extension, and I just tried it again. It has no effect.

To make sure this wasn’t a problem with the datastream coming from the applications I use, I tried opening the IRS W4 PDF from their site, and it downloaded instead of displaying. There is clearly a problem here somewhere.


#4

Hm… @sriram, were you ever able to find a solution to Unable to view PDF on MacOS? Or is there a corresponding Github issue for this? I briefly scanned Github and found related issues for PDFs (such as leading to error pages), but not necessarily forcing a download instead of displaying in-browser like in these cases.


#5

Hi @RisoSystems @chriscat,

An issue logged for this here

Best,
:slight_smile:


#6

I did search and the similar issues I found had been closed.


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.