Pdf files are not opening with Brave Beta


#1

I am using Version 0.55.11 Chromium: 70.0.3538.35 (Official Build) beta (64-bit).
While opening pdf documents from pubs.acs.org website I am getting error message saying invalid or corrupted pdf file. image attached.
I remember seeing the same error for Brave regular (muon) as well. Similarly Brave Dev also showing the same error. No addons are installed.


#2

Can you show me where you’re opening the pdf on the page? I’m not a member so I’m unable to view the whole text. I imagine you’re more than likely running into this:


#3

Thanks for the info.
But I am not clear what you mean by “Show me where you are opening the pdf on the page?”. I have access to the website to read full article. If click pdf link for an article it normally opens a new tab where I could read the pdf document. That is the normal case with Firefox and Chrome. But for Brave I am getting error message. Other websites just work fine.
If you mean what is in the address bar I see that linked to an extension, probably pdf extension. I copied updated fig here.
Thanks again.


#4

So it looks like you’re running into this:


Looks like one of the few issues carried over from browser-laptop still present. I’m going to ask around about the status of this because I don’t see this particular error actually logged in our Brave-core repo.
Will reply when I know more.


#5

This is a really annoying behavior. I get a lot of these errors.

Is there a work-around?


#6

@antokhin, this is more than likely due to the same issue. There are several additional related issues revolving around PDFJS right now open in GitHub:



It’s likely that these will be resolved in the same update. I’m going to reach out to the team and make sure your (and @nellaiseemai) reports make it to the right issue to +1 them. Will update here if I have more information or after I’ve added your reports so you can verify.


#7

Thanks for your help.
Yes. This is the correct one - Issue: PDF protected by login does not load
I was not clear in my comment earlier.
Only pdf documents from pages which need log in has issue. Other open pdf documents open fine.
Thanks


#8

Excellent, thank you.
I’m going to add your (and @antokhin’s) report to the issue for the team to see. It looks like this is fairly high priority (has the P2 label) so the team is likely already working to address this. I’m going to leave this thread open for now in case other users would like to add their reports to the thread.

Appreciate you both taking the time to bring this to our attention.


Cannot view the pdf file on the browser
#9