Passwords missing after TimeMachine restore

Description of the issue:
Previously saved passwords have not migrated across after performing a TimeMachine restore. I have tried to copy the default folder from the backup itself but I then get a ‘Some settings were reset’ message.
Is there a way to restore passwords using a file from a previous time machine?
How can this issue be reproduced?

1.Delete all data from the Macbooks harddrive
2.Reinstall MacOS Big Sur
3.Once installed use the OS’s prompt to restore from TimeMachine. Pick the most recent TimeMachine backup.
4.Once complete open Brave and navigate to saved passwords
5.None appear

Expected result:
I would have expected the passwords to migrate across unless I am doing something wrong.
Brave Version( check About Brave):
Version 1.23.75 Chromium: 90.0.4430.93 (Official Build) (x86_64)
Additional Information:

Hi there @TowerNorth, welcome to community :slightly_smiling_face:

On macOS, passwords are typically stored on the keychain which Time Machine does backup. You might possibly have to re-grant access to keychain for Brave.

Try giving this a go…

  1. Open Keychain Access.app
  2. Search Brave Safe Storage
  3. Double-click the entry found, click on Access Control tab
  4. Press the + button in the bottom-left corner, and find Brave Browser in your /Applications directory
  5. Upon seeing Brave Browser added to the list, tap Save Changes and enter your password
  6. Re-launch Brave

Best,
Salty :banana:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.