Password view/hide button in password manager is inversed

Kind of a small bug, more of a qol one.

note: I am using mac, i don’t know if this is also a bug on windows

also for some reason when searching up the correct tag for this, searching “bug” comes up with nothing, but searching for “bug” in the main page comes up with bug.

Steps to reproduce:

  1. Launch Brave
  2. Open Brave settings (command + , on mac)
  3. Go to auto-fill
  4. Open password manager
  5. Click the 3 dots next to any password
  6. Click “Edit Password”
  7. Click the view button

Actual result:
The symbol has changed to hidden, and the password is in view

Expected result:
The symbol has changed to view, and the password is in view

Reproduces how often:
Always

Brave version:
v 1.45.123

Reproducible on current live release:
Yes

Additional information:
I’m using macOS Monterey Version 12.3 and m1 chip

also this is my first post, i created my account for this

Hello @tacomelon, thank you for bringing to our attention. Could you please share an screenshot so we can have a better idea? Thanks in advance.

Hello @tacomelon, I see, thank you for letting us know about this. Usually these issues are resolved by clearing cache and data have you tried that? Additionally, please answer the following questions:

1 - What kind of device and OS do you have?

2 - Have you updated to the latest Brave version? If this is a desktop computer found at brave://version to download the most recent one https://brave.com/download/

Regards.

Yeah, clearing the cache worked.

Thank you

Hello @tacomelon, thank you for letting us know it worked. If you have any other concern we we will be happy to help you. Regards.