Password Auto Fill

i have password options turned off on the browser but it keeps auto filling the password for me, and its the wrong password at that. I cant figure out how to clear it when password filling is turned off.

1 Like