Pages in preview mode when I switch between apps

Brave 1.44.101, Chromium 106.0.5249.65, Android 9

Many times I switch between apps and back to Brave, the page enters a preview mode and soon reloads, clearing filled form data in the process. I only noticed this recently.

1 Like

Hello there @beecauliflowerrocket in order to provide you further assistance, please provide the following information in order to investigate further:

  1. Description of the issue:

  2. Steps to Reproduce (add as many as necessary):1.2.3.

  3. Actual Result (gifs and screenshots are welcome!):

  4. Expected result:

  5. Reproduces how often:

  6. Device information and Brave Version(See the About Brave page in the main menu):

  7. Additional Information:

Be waiting for your response.

@Kevin_cc I’m not sure what else should I provide beyond what I already did. All you asked is already there. It’s simple as that: switch between apps and, sometimes, you will see the page in preview mode that quickly reloads to the live version, clearing any filled forms in the process.

1 Like

Hi @beecauliflowerrocket. I think I have the solution. I ended up digging deeper since there was no answer here. I believe the problem comes from an overzealous power management system in Android. Brave was being closed in the background, sometimes very quickly. I’ve changed Brave from “manage automatically” and I think it’s sorted.

Android system screenshot attached.

Hello again, please try enabling Brave to run in the background to see if this no longer refresh everytime you switch between apps.

  1. On your phone, open the Settings app.
  2. Tap Apps.
  3. Tap the app you want to change. If you can’t find it, tap See all apps. …
  4. Tap Permissions. If you allowed or denied any permissions for the app, you’ll find them here.
  5. To change a permission setting, tap it, then choose Allow or Don’t allow.

Additionally, please try switching tabs on different browsers to see if the issue is not only limited to Brave.

Let me know if that works.

At least in the version of the Android I’m using, the permission to run in the background is in the Battery section, although for Brave I’m not allowed to change it. But it seems to be that it is turned on by default, so it’s probably all good here.

I also tried what @Cylindricalsea suggested. On Android 9, I couldn’t find the exact setting they mentioned, but I turned off the battery optimization for Brave. I’m still not sure if it worked. I still see pages in preview mode sometimes, but it doesn’t seem to happen while I’m switching between apps anymore.

1 Like

If the issue still persist and you see them on preview mode, please try the following:

Go to Settings > Device Care > Battery > Power mode and select High Performance (or Optimized Performance).

Let me know if that works.

Just reporting that I’m still having this issue. Maybe it’s related to the low available storage I currently have on my phone.

1 Like

@beecauliflowerrocket have you tried cleaning some storage and RAM on your device to see if the pages you have open in Brave do not reload?

Be waiting for your response.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.