Page Rendering issue

Description of the issue:
I have just loaded up Brave to make a brave attempt to get off the Chrome browser. I have loaded all my extensions and bookmarks and opening tabs which has almost been seamless.
I have found one issue. My own Wordpress site does not render properly.
I have reviewed everything I possibly can and can confirm my site renders properly on
and Vivaldi

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Open site in Brave (
Now compare the page alignment with any of these other browsers.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:
All the time

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 Enterprise
Brave Version 0.63.48 Chromium: 74.0.3729.108 (Official Build) (64-bit)

Additional Information:

This is due to the ad at the top being blocked which produces the whitespace you see. That said, it shouldn’t be producing that much whitespace – instead, it should just block the ad and fill in the space with the page content below.

I’ll reach out to the team to see if anyone has input on where the whitespace is coming from. I’ll let you know what I find out.

1 Like

I disabled the add blocking through the settings and the issue is still present. My concern is that I don’t see this on any of my other browsers with or without 3rd party add blocking, so it must be something they have done in the code for the Brave browser.

I won’t be able to swap over until it is resolved as it looks unsightly and it is my own web page.

I’ve filed an issue on our Github to capture data surrounding this:

However, you’re saying that even after allowing ads/trackers you still get the additional white space? Can you show me your Shields panel while on the site as I’ve displayed below?

1 Like


Ok, so there was one difference and that was a 3rd party device recognition blocked message. I then selected all device recognition allowed and the page rendered correctly.

How do I find what the device was that was being blocked?

Actually no. It did render correctly when I set the all device recognition allowed, but when I closed and reopened the browser, the issue presented itself again.

I’m running the exact set of extensions I run on the normal google chrome browser and loading all the same pages I do in chrome. This is not making sense given the core code is the same.



Another example, default Shields.

The consequence of that is I’ve had to install uBlock Origin to block the necessary element.

This topic was automatically closed after 30 days. New replies are no longer allowed.