Page not loading when clicking on link

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting


Description of the issue:
How can this issue be reproduced?

  1. Go to any page ( for example https://community.brave.com/)
  2. right click on a link (for example browser support)
  3. open in new tab
  4. New tab opens with the link and remains in a loading state
  5. Click on stop (X) and refresh (the round arrow)
  6. Page opens in the tab

Expected result:
Page opens directly in step 4

Brave Version( check About Brave):
Version 1.39.111 Chromium: 102.0.5005.61

Additional Information:
It as a pretty fresh install , max 2 weeks

Do you see this same behavior if you try the same steps using a Private browsing window?

yes I do, also after restarting the OS, the beviour is consistent.

Interesting — can you please update to the latest build (released today — v1.39.122) and tell me if this resolves the issue or not?

1 Like

@michael1234

I have been wondering, exactly what the ‘round arrow’ actually is called (tx to ‘toptal.com’):

‘Open Circle Arrow’:

Open_Circle_Arrow

1 Like

Hi ,

yes, I am trying to do that, but when I go to ‘About Brave’ and then click on the version , the update is not installing, instead the page https://brave.com/latest/ is opening.

I searched in settings and online how to enable updates, does such a setting exist?

image

@michael1234

Latest v1.39.122 at:

Please be certain to ALWAYS back up your BraveSoftware folder, prior to running the installer.

On the Linux machine, the BraveSoftware folder might be located at:

  • $HOME/.config/BraveSoftware/

PS. If not using KDE instead of GNOME, you might try that.

1 Like

ok, I have installed this version manually using the instructions.
Now it works when middle clicking a link on a page - it opens in a new tab without the need to stop and refresh. :+1:

Strange though from search engine results it still needs the refresh, I tried brave, duckduckgo and presearch . Is my assumption correct that this will be addressed in future fixes? I read about issues when setting specific search engines as default on other topics.
I changed the default search engine to duckduckgo , but the same happens.

Also I saw that stop and refresh is needed when entering an url in the adress bar and hitting enter.

@michael1234,
The page refresh issue may be related to this (known) issue:

As for the search engine, is the situation that you’re not able to change the default search engine for the browser? Or am I misunderstanding?

1 Like
  • Thank you for the tip; I started the browser with the “–enable-features=NavigationThreadingOptimizations” setting and pasted brave.com and hit enter. The page did not load. Then after deactivating protection from the brave symbol the website loaded. I see that the issues are well known to development so I trust they will be fixed in future updates.
1 Like

Same here. I don’t really know how to reproduce it, but sometimes (often) my pages just don’t load, and need to “stop” and “refresh” to make it work.

1 Like

The issues with page not loading from different opening methods seems to be resolved in my installation, although the version is now still 1.39.122 . Thank you to the developers :+1:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.