Optional Tags are 'Required' but selections are not allowed

I just tried to submit a question in Browser Support but it required me to select an ‘optional tag’. When I selected one of the listed tags - the macOS one - I could not create the topic because the selected tag was not allowed within the section.

So I tried to create a topic in another area which I was allowed to do but I received a notification that I wasn’t allowed to post and a moderator would have to approve the post before it would be posted.

Sorry but this is not cool.

@LudicrousSpeedGo,
Sorry for the issue — not sure why it’s doing that. Was working as recently as 25 minutes ago so not sure what would have changed. Looking into this now.

Thanks for taking a look at the problem.

When will my actual question get posted though? I don’t understand why a moderator is required to clear the question but regardless when will a moderator even look at it? Will I receive a notification when its released or a chance to edit the post if something is deemed to prohibit the posting in its current form?

I just approved the post.