Opensuse install "GConf2 needed by brave-0.13.0-1.x86_64"


#1

On my laptop I have openSUSE Leap 42.2, KDE desktop, with the latest updates. I tried to install brave according to the instructions. First installed lsb, then added the repo. But the command zypper install brave came up with:
Problem: nothing provides GConf2 needed by brave-0.13.0-1.x86_64
Solution 1: do not install brave-0.13.0-1.x86_64
Solution 2: break brave-0.13.0-1.x86_64 by ignoring some of its dependencies
I checked - on my laptop is the package gconf2-3.2.6-10.2.x86_64 installed - so what is the problem? Any ideas are appreciated.


OpenSuSE, Brave install, missing gconf2
Linux update: NOKEY
#2

I submitted a bug report on this:

The bug report also shows a second conflict with libXScrnSaver. It may be that they left a couple dependencies in accidentally. The problem is in 13.0 and 13.1 so far, hopefully they will fix this for 13.2.


#3

Thanks for the reply. I have looked through all the “help Me!” topics and had a quick search on the Internet on ‘brave install on openSUSE’ and didn’t see anything similar. Will check your bug reports.
I didn’t use Yast but zypper and the result is posted above - so far only the conflict with Gconf2. That is exactly what I get from zypper:
Resolving package dependencies…

Problem: nothing provides GConf2 needed by brave-0.13.1-1.x86_64
Solution 1: do not install brave-0.13.1-1.x86_64
Solution 2: break brave-0.13.1-1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] ©: c
By the way versions 13.0 and 13.2 reached their end of life, 13.1 still is supported for a while. The actual versions are Leap 42.1 and Leap 42.2. As I wrote above - I have the latest gconf2 package installed and wondered if the problem is the spelling gconf2 vs GConf2 which could be solved with a sym link. Would be interesting as well to find out what particular gconf2 would be requirement (e.g. version 3.0 or higher).


#4

13.0 and 13.1 are the Brave versions this bug exists in so far, not OpenSuse versions.


#5

Sorry stan_qaz - I have seen that now after reading your post and submitted reports. In the meantime I have installed gconf2-devel and libgnome-keyring-devel and libXScrnSaver and I still get the result “GConf2 needed by brave-0.13.1-1.x86_64” no matter whether I use zypper, rpm or Yast.


#6

I just downloaded the 13.1 tar.bz2 file extracted the files and the browser runs from there. There is no need to compile after unpacking. (Of course I have to open it from ~/Downloads/Brave-linux-x64 directory for now.) But I can play around with it to see how much I like it.


#7

Following the directions here I was able to reproduce the issue. (Using OpenSuse Leap KDE on a VM)

After hacking around for a bit, I decided to go with Solution 2 and install anyways. Brave loads without issue and haven’t noticed any bugs.

I know it’s not ideal/a little scary to see those kinda warnings, but I think it’ll at least work enough to try it out. Do let me know if you notice any bugs though.

I’ll also pester the dev team a bit to see if we can’t clean up that dependency.


#8

Installed 0.13.2 from Yast and only saw the gconf error, selected install anyway and Brave has been working fine so far.

Cleanup would be less scary for many folks that fear a broken system if they push a button they aren’t familiar with.


#9

Yes - it seems to work. However installing with zypper brought up this:
brave-0.13.2.x86_64.rpm:
Header V4 RSA/SHA256 Signature, key ID 448eee6c: NOKEY
V4 RSA/SHA256 Signature, key ID 448eee6c: NOKEY

brave-0.13.2-1.x86_64 (brave-rpm-release): Signature verification failed [4-Signatures public key is not available]
Abort, retry, ignore? [a/r/i] (a): i
First I clicked abort then I checked the package:
rpmkeys --checksig brave-0.13.2.x86_64.rpm
brave-0.13.2.x86_64.rpm: sha1 md5 OK
I tried again and got the same message (same key ID). This time I selected ignore and the package installed. It seems to work so far. Will try the install on Tumbleweed hopefully later this week. But it looks as if there is still some work to do on the packaging. It is one thing to install on a virtual machine this way where you can go back easily and not damage a system and another thing to do this install on a machine which is needed daily.
Cheers
Uli


#10

By the way the software repository is not signed. Ironically a secure and private browser missed to firm its repository.

I try to add it yesterday (20-Sep) and yast complain about it.So I freeze its installation until a signed repository is provided.


#11

It looks as if they are not concerned about the users of openSUSE. With those error messages I have received when installing Brave on one of my computers (one which is not so important and used for testing). But with the computers I need for work every day I don’t take a risk. Unless I hear that they fixed the packaging for openSUSE I won’t use the Brave browser. I use firejail a lot for sandboxing instead.


#12

The team is working on that issue here


#13

Still the same problem:
linux-tl1r:~ # zypper ref
Repository ‘Packman’ is up to date.
Repository ‘Skype’ is up to date.
Retrieving repository ‘brave-rpm-release’ metadata ----------------------------------------------[/]
Warning: File ‘repomd.xml’ from repository ‘brave-rpm-release’ is unsigned.

Note: Signing data enables the recipient to verify that no modifications occurred after the data
were signed. Accepting data with no, wrong or unknown signature can lead to a corrupted system
and in extreme cases even to a system compromise.

Note: File 'repomd.xml' is the repositories master index file. It ensures the integrity of the
whole repo.

Warning: We can't verify that no one meddled with this file, so it might not be trustworthy
anymore! You should not continue unless you know it's safe.

File ‘repomd.xml’ from repository ‘brave-rpm-release’ is unsigned, continue? [yes/no] (no): yes
Retrieving repository ‘brave-rpm-release’ metadata …[done]
Building repository ‘brave-rpm-release’ cache …[done]
Repository ‘Main Repository (NON-OSS)’ is up to date.

All repositories have been refreshed.
linux-tl1r:~ # zypper install brave
Loading repository data…
Reading installed packages…
Resolving package dependencies…

Problem: nothing provides GConf2 needed by brave-0.18.36-1.x86_64
Solution 1: do not install brave-0.18.36-1.x86_64
Solution 2: break brave-0.18.36-1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] ©:
linux-tl1r:~ # rpm -qa | grep gconf2
gconf2-lang-3.2.6-12.3.noarch
gconf2-3.2.6-12.3.x86_64
gconf2-devel-3.2.6-12.3.x86_64
gconf2-branding-openSUSE-42.3-1.2.noarch
linux-tl1r:~ #


#14

As I wrote earlier today (unfortunately I am very busy today) in the copy of the command line, it still looks as if GConf2 is not recognised, possibly other items are not resolved either. Although not an IT guy I am maintaining the 4 linux computers/network of our little company and there I don’t take any risks.
Cheers
Uli


#15

The PR above has been merged to the master branch.