Opening links doesn't block trackers/ads?

Hello Community,

I’m having an issue on my Samsung Galaxy s10e where if I open an article or link that isn’t just a domain name. For example, if I open CNN.com it will block ads however if I find an article on CNN on their website or the internet search engines and once I click on the link it won’t block any ads or trackers. This includes going to CNN.com which will block about 44 ads or trackers but once I click on an article it does not block on ad or tracker. I am just wondering if this is an ongoing issue for anyone? It just seems odd that only the domain name (youtube.com, cnn.com, theverge.com) is blockable. Does anyone have any suggestions?

Brave version 1.5.9
I am running android 10.

Thanks for any help anyone in the community can provide.

I believe its just a bug, it’s still being blocked. Just not being reported. Brave Beta on Android should have this fixed (if you want to test).

I tried the beta but the beta doesn’t block anything on my device or at least doesnt tell me it blocks anything. So just wondering if it’s blocking trackers or not.

Anyone from the support team can address this issue? I’d like to quit Firefox but this issue isn’t letting me to switch fully on mobile.

Thanks

Just tested cnn.com (Screenshot of Brave Beta 1.5.116 on Android, OnePlus 6 Device). The verge.com was also fine, showing 23 Blocked items. I would clear the cache on Brave Beta (as a start)

Yes if I type the URL edition.cnn.com I get same about you in blocked Ads and trackers. However, if I click a link It does not display blocked trackers. I’m not sure the issue because it will block trackers, but if I click links it wont block anything because I have tried it. For example i will load youtube.com and then if I click on a link in youtube.com it will show ads. I will post a screen shot if that helps

Hello fanboynz,

I think my adguard mobile app was conflicting with it, now its working fine. Thanks for your help.

This topic was automatically closed after 41 hours. New replies are no longer allowed.