Open url mail to protocol (checking always open these types of links doesn't work)

checking the box to always open thees types of links doesnt take i have to click the open url mail to protocol each time so it executes the javascript i have in the url

my java script is ( javascript:document.location=‘mailto:?subject=’+document.title+’&body=’+escape(document.location); )
see screen shot

Do you have Brave set as your default browser?

yes cant you repeat it? windows 7 machine at work

havent tried it on my windows 10 machine at home

See if any of the solutions/suggestions mentioned in the the thread below solve the issue for you:

I think I am having the same URL:mailto issue. Each time the pop up about whether to open Thunderbird. Setting is not retained. No change when making Windows Mail default. Suggested registry fix is not a solution with or without double dash. Performed the three tests which all work fine.

Edge as default browser pops a message ad infinitum about if I am sure to make the switch to a different app: Microsoft Edge tries to open Thunderbird. Setting not retained either.

In all instances Thunderbird opens as expected, after giving confirmation.
Windows issue?

Brave 0.64.75 Windows 10

It very well may be!

Followed the instruction to no avail. If anyone likes to try here is the edited registry file for Brave. Make sure to go over the linked IE file first as this forum omits double backslash.

Windows Registry Editor Version 5.00

@="“C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe” -nohome"
@="“C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe” %1"


@="“C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe” -nohome"
@="“C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe” %1"



This topic was automatically closed after 30 days. New replies are no longer allowed.