On Youtube.com brave blocks the videos not only the ads

Description of the issue:
Hello Today I try to watch some youtube videos, but brave shield block the vidoes. When I press play the sound of the videos starts, no adds are loading , but the videos shows only a black screen. This happens on every video.

Exact URL of the website in question:

Screenshot of the ad as it appears in Brave

Did the issue present with default Shields settings? (yes/no)
Yes the shield was ON, If i turn it OFF the videos start normal but with adds

Does the site function as expected when Shields are turned off?

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
The normal settings for the shield

Does the site work as expected when using Chrome?

Brave version (check About Brave):

Version 1.56.14 Chromium: 115.0.5790.114 (Official Build) (64-bit)

Haven’t seen such behaviour on my brave installations yet. Do you have any other ad block lists added ?

I also am not seeing this. Also curious about what extensions you have installed and also whether or not you see this behavior if you were to view Youtube content in a Private browsing window?

It started for my brother and now me today actually. The only solution was to disable the shield and let the uBlock extention do the work. This is the same behavior I’ve observed on some other sites and usually gets fixed fairly quickly. It’s best to have both but clearly Youtube doesn’t like that anymore. In his case, there’s no play button at all just a black screen.

Did you have uBlock running at the same time? Keep in mind you want to not have as many things running at the same time. It can create conflicts. Same is true of enabling a ton of filters.

One thing that would be helpful is if you can try it on a private window and see if it replicates there. (it tests for cookies but also to see if any extensions are creating issues).

Also have to ask, what Shields settings are you using? You don’t have anything like Block Scripts enabled, do you?

@dreamkeeper I’m not seeing extensions on yours, so might not be an issue. But could you share what your Shields settings are like? For example:

Also have to ask if you have any filters enabled over at brave://settings/shields/filters

But when I tested, have no issue:

This was after I enabled shields and played a random video on a private window. Before enabling the shields, there were ads. The only filters I have enabled are the EasyList Cookie, Fanboy’s Annoyances, and the uBlock Annoyances one. Disabling them did nothing at all. I don’t block scripts at all as I see no need to do so. The shield settings are set to aggressive, HTTPS connections, and cross-site cookie block. That’s all. My test concluded that the video on the private window simply refuses to play while the main window it flat out doesn’t load but it does block the ads nontheless.

Disabling uBlock on the site and leaving the shield on didn’t help if you’re wondering about that too. I tested that as well. To be safe, I’ll disable two of the filters anyway as I already have the Fanboy’s list in uBlock.

Thanks for that @Ziko. I’m going to ask you to try 2 more things if you would, followed bY another question or two. If none of them resolve, then will tag in Fanboynz or Mattches again for their insight.

Try each below separately:

  • Go to your hamburger menu image and Create a new profile. Does the issue happen there as well?

  • On your original profile, can you go to brave://components and make sure Brave Ad Block Updater is Version: 1.0.394 or later.


  1. Have you changed anything at brave://flags?

  2. Are you using a VPN? (if so, does temporarily disabling make a difference?)

The components are all up to date and no flag changes to note and I don’t use a VPN. Nothing I did resolved the matter.

@Ziko Did you try new profile? That was final test. Was asking that as it kind of collectively makes sure that extensions, cookies, and settings aren’t to blame. The new profile essentially just starts off fresh (except anything on brave://flags remains implemented).

Just trying to confirm as don’t want to make any assumptions, so usually just go by exactly what a person mentions.

The site barely functioned on the second profile at all actually. It did play a video for a bit with the shields on but often it led to the offline site error when I clicked another one. I couldn’t even search for anything specific in the bar. There’s something busted going on that’s for sure.

EDIT: I can’t believe this but after I went back and tried again, having the shields on and the option to allow ads & trackers let’s the site work properly believe it or not! What? Why would I want that as an option? uBlock will block the stuff but just to be on the safe site, I’ll leave the shield off for the time being like I did on Tokuzilla a while back until you all do your thing.

EDIT 2: Apparently the offline issue and other stuff is related to a technical issue on their end as others have reported to them on X as the home & search pages don’t load occasionally and requires a refresh to sometimes works. Here’s the post on reddit regarding the issue: https://www.reddit.com/r/youtube/comments/15gmuwk/something_wrong_with_youtube/
I can’t comment further there myself because I am prohibited from doing so on that sub. I also wonder if it’s related to videos not loading on Brave too as others have reported that it works ok on Chrome & it worked fine on my phone as I use Brave on it too.

@fanboynz I want to tag you in here in case you can offer some insight.

@Ziko Only other thing I haven’t asked of you that often I’ll see @Mattches or others ask if for you to try with a Brave Beta or Nightly build. Not sure if you’d like to try downloading either of those. You can get Nightly at https://brave.com/download-nightly/

I also failed to ask what OS and version of Brave you’re using. Beyond that, I tried to ask for some of the basic info and troubleshooting steps many ask to be taken. So at least have a bit of a “triage” for them. Hopefully enough that they know where to better guide you on info they need or on offering solutions.

I’m still on Windows 7 which Brave no longer receives browser updates for and the last version of it would be 1.47.186. I can’t get a new PC to get the new updates neither as well, that’d cost a bit of cash. Beyond that, I still use it regardless as the last browser I used to use went through some drama and it no longer became viable to use for Google based sites. I just keep it because it may be needed for a fallback in case something goes wrong on Brave which is extremely unlikely at this point.

Ah, that might be part to do with it then. A lot of things are changing on the internet and definitely within Brave. As you know, your OS is no longer supported by anyone. I’m not sure if they’ll have any help for you on it, but guess we’ll have to see.

@dreamkeeper, will be waiting to hear back from you on some of the things had advised Ziko above. Things like Shields settings, trying in private, testing with new profile, updating components etc.

It’s beyond frustrating but I really have no alternatives that are as good as this browser. So far, what I did do is working fine so for now that’ll be the way to go. I can’t upgrade to Windows 10 on this PC and Linux is a no-go for me. What I have works really well and I use programs that still get updates that run well on this OS though they probably shouldn’t. :sweat_smile:

It makes me wish that if there was a fork of this browser much like Pale Moon was once a fork of Firefox, would probably solve some of these issues immediately perhaps. The problem is when Google did what they did with the coding years ago, kiss YouTube or anything Google related goodbye with your performance tanking on a non-Chromium browser. I have faith a solution will come through as it always has. Good luck guys!


Can you test the following in brave://adblock

www.youtube.com,www.youtubekids.com,www.youtube-nocookie.com#@#+js(aost, JSON.parse, /doEnqueue.+?polymer/)

If that helps, try also in brave adblock

youtube.com##+js(aost, JSON.parse, /(Lgb|Vgb).+?prototype\.doEnqueue[ \S]+polymer/)

Save and reload youtube.com webpage, let me know if the 1st filtered helped? and if the 2nd filter still causes issues or not.

Neither filter did anything for me after re-activating the shields plus the comments section gets stuck in a loop.

Assuming on windows; Close Brave, then re-open once the following change:

C:\Users\(username)\AppData\Local\BraveSoftware\Brave-Browser\User Data\iodkpdagapdfkphljnddpjlldadblomo\1.0.394

Edit “list.txt” line 34:

and just comment out

! www.youtube.com,www.youtubekids.com,www.youtube-nocookie.com##+js(aost, JSON.parse, /doEnqueue.+?polymer/)

Then save the list.txt, and re-open Brave. Retest Youtube.

Thanks for helping, really appreciated.

1 Like

I can happily report that deleting the offending line of text fixed everything. Thanks for everything! No more annoying ads slipping through. I’m not sure why that even happened so I’ll assume it’s YouTube shenanigans as always.

Sounds good. Does replacing it with:

youtube.com##+js(aost, JSON.parse, /(Lgb|Vgb).+?prototype\.doEnqueue[ \S]+polymer/)

(editing the same list file), save and reload Brave. Break Brave or not?

It does. I’ll just leave it out for now until something can be done.