Omnibox not autocompleting the right thing. "gmai..." autocompletes to random stuff before it lists my gmail inbox

Description of the issue:
When typing in the omnibox, I’d like the suggestions to be ordered better.
Brave shows random “common google searches” before my own history. In chrome, I require less typing / clicks to end up at the page I want (gmail, in this case).

How can this issue be reproduced?
By typing “gmai” in the omnibox.

Expected result:
Chrome autocompletes “gmail” completely from me typing the letter g and onward.

Brave Version( check About Brave):


Additional Information:

Hi @fruityth1ng, Welcome to Community!
Very odd, I’m seeing as my top result when I type g.
Can you go to brave://settings/appearance and toggle with the following settings:
Show autocomplete in address bar
Show top sites in autocomplete suggestions
Show Brave suggested sites in autocomplete suggestions

1 Like

That was it!

I did not have “Show Brave suggested sites in autocomplete suggestions” checked.

Thank you so much, this was driving me nuts :smiley: