Old Version for Old Laptop

Are there older versions of Brave available for older laptops that cannot (or not safe to) update further? I’m using a MacBook Pro operating on 10.14.2 and have been advised to not update further as my laptop will not support all updated apps

@servingfish11,
Thank you for reaching out to us.
Users on the OS version you’ve listed can visit our Github to download the last available version (1.57.64):