Odysee.com not loading on Brave

Sometime on 6/21/23 Odysee.com stopped loading on Brave desktop (with shields up and down), only displaying a blank white page.
I have no problems loading other sites.
Odysee.com does load on the Odysee app, Google Chrome on desktop, and Brave browser on Android.
I relaunched the browser, restarted my computer, updated the desktop Brave browser, but still I get the blank white page.
Any ideas?

  • do you have any sort of proxy or vpn activated?

  • Also maybe clear your custom filters in brave://settings/shields/filters if you have anything blocked there

  • Make sure javascript is enabled by clicking on the lock icon in the top left

  • Try clearing cookies on odysee too

These are my best guesses for what’s happening here, let me know if these work, fingers crossed!

1 Like

•I don’t have any sort of proxy or VPN activated.
•All custom filters cleared.
•Javascript was enabled.
At first I could not locate “the lock icon in the top left”. Maybe next time say ‘the lock icon in the left of the URL window’ as I was looking above and to the left of it’s location.
When looking for the lock I clicked on a button that showed my multiple Brave user profiles, of which I had three. Not sure why I made three, so I selected the original one. I then went to Odysee and it loaded as it should. I just loaded “odysee.com” so it wasn’t going to any specific URL I have when logged into my Odysee account. While it loaded on the original user profile, it still would not load on the other user profile I had used at first.
At that point I did not bother to clear my cookies on Odysee, as the user profile I desired to use worked just fine with the site. I have since deleted the old user profile that did not work with Odysee, so problem solved. I will try clearing the cookies should this problem return in the future.
Thank you.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.