Noticed Brave Now starts about 17+ Processes causes memory leaks

--------Delete this line and everything above before posting---------->

Description of the issue:

Version 0.68.142 Chromium: 77.0.3865.90 (Official Build) (64-bit)

Every time I start Brave Browser 17 processes start and the browser becomes very very slow to access any sites. It slows down that I wait for about 5 minutes to access a site and do anything.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Start Brave Browser
  2. Look at task manager and you see 17+ processes start
  3. Then after trying to look at the news or anything, by creating another tab, it starts to get slow.
  4. Working on my Word document, I get a error that there is not enough memory and it cannot save.
  5. The text notepad document blanks out and I no longer see the words.
  6. I have to hard boot and start my system again.

Actual Result (gifs and screenshots are welcome!):

Expected result:

I expect the browser to be fast and not to start so many processes and then hang when I try to access another site or do anything.

IT also starts to deplete my memory - I believe there is a memory leak and all of a sudden I am not able to do anything like open folders, save my word document, etc. The graphics is not rendered and I no longer see my folders. I have to actually HARD BOOT my computer.

Reproduces how often:

Every day

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10
Brave version: Version 0.68.142 Chromium: 77.0.3865.90 (Official Build) (64-bit)

Additional Information:
That’s it. At times I have to start using my Firefox again because it is much faster and it doesn’t hang. I also do not see many updates for the browser.

It because Brave use multiple processes. One for main process, others for tabs, extensions, etc.

cc @Mattches for “memory leaks” issue.

@DJM,
This may be because of the number of extensions you have installed, as well as the number of tabs you have open. Can you try launching a Private window (or “Guest” window) session and see if you get the same behavior?

Hello Mattches,

I only have 6 extensions and only 4 are enabled. I have at least 3 times the amount on FIREFOX and I never get these performance issues. Does anyone run performance test scenarios?

The Private Window is fast at first and if I open up the third tab, it slows down. Performance is very bad.

I noticed the graphics on the page on what I am looking at does not render, it takes about 3 minutes. This is poor performance.

My Experience is in Software Quality Assurance for he past 18 years, 5 years with Tech Support and 15 Years in IT. So I have tested and worked for many companies and we never accepted this kind of performance.

When are the new drops for Brave going to be?

1 Like

Also when I look at Twitter “TREADREADER” none of the images never render. When I use Firefox, I have no problems. There is a real performance issues with BRAVE. You need a team of Performance Engineers to run Performance in all scenarios.

@DJM,
I ask about extensions because [at least] one of them may be conflicting with the browser and causing performance issues.
Further testing:

  • If you open a guest window, the browser will load with a fresh profile – can you check the performance in a guest window session?
  • Can you try disabling Hardware Acceleration in Settings to see if that helps the general performance issue?
    Settings --> Additional Settings --> System --> Hardware Acceleration
  • Would you be willing to download/install our Beta build to see if it exhibits the same performance issues as the stable build? Note that this can be installed and run alongside stable without overwriting or removing any data.

Same problem here, with 15 processes when only one tab is opened, which I did just now. Normally I then open a non tor private window and close the normal window.

I would not have awaited that my search for the freezes of my notebook that I lately receive come from me having one tab open in a private window in brave. Somethings going wrong definitely. For now I didn’t open a webpage, it stays at 300MB and growing, CPU usage is not so high at 0,2% but over time this grows to nearly 2 GB with high CPU usage. At one point in time the notebook is freezing then.

I installed “Tab Suspender” to try to tackle this “Monitor and Clean system’s CPU / RAM usage” and enabled it in private but strangely even when I put this one tab into suspend Brave is using high CPU. Nothing is fixing it and update says it’s already on the newest version.

Guess for now I can’t use Brave then. After the last numbers I mentioned in this post brave is now at 450MB RAM and 0,7-1,4% CPU. It’s not related to the extensions I enabled in private, it happened without them as well. Also not with the website I normally open since it’s not open now. But I have two instances of the same website open in chrome at the same time without problems. But will let it stay open and observe. If nothing happens I will try with the website open.

Thank you!

Only an update. After a day brave had over 2GB or RAM and 50-75% or CPU usage. I only had one private window open with one website open. Then I opened a new private tab and closed the website tab. Nothing meaningful changed with the RAM and CPU usage. I had to close brave to get rid of the performance issue.

It’s not the website, I have it open in 2 other chrome tabs without these issues.