[NOTICE] Update on iOS Transfer issues

Hello, Community!

We wanted to give an update on issues related to the transfer of funds from your iOS to Desktop device after the updating to v1.22 (Legacy/QR code transfer). We understand that the process did not work or did not work exactly for many of you which I’m sure is frustrating and even more frustrating to not know the status of the issue or when it will be resolved. Please note that, while the issue is particularly complex, we intend to ensure everyone receives any due payment.

If you haven’t been able to successfully transfer your funds from your iOS device to your desktop browser, you’ve likely fallen into one of several possible “bad states”, which are listed below along with why you may be in that state and what we are doing to resolve the issue. Please read the following carefully and see which state applies to you.

The iOS transfer process appeared to work successfully for me, but my funds never transferred

This scenario likely accounts for the majority of users encountering the iOS transfer issue. This particular state is caused by a larger issue in the code/process, causing your funds to become “stuck’’ mid-transfer. This issue falls on us to resolve and, at this time, there aren’t any actions needed from the user end of things.

In fact, once we’ve implemented a fix for this particular issue, any “stuck” funds will be drained into their appropriate wallets as the transfer completes and your transferred BAT will just show in the browser desktop wallet you transferred to. We apologize for the inconvenience and want to assure you that we are prioritizing this and hope to have it resolved as soon as possible.

I do not see/have never seen the option to perform a transfer on my iOS device.

If you’ve never seen this option, it is likely due to the fact that you installed the browser after the December 15th cutoff date – anyone who installed the browser after this date will have installed v1.22 of the application and will not see the option to transfer.

When attempting to transfer funds from iOS, I received a “Connection Error”

Users may be facing this particular error due to the fact that they were using an outdated version of the browser (v1.21 or earlier), enabled Rewards after the Dec. 15th cutoff date, then updated to v1.22.

Another reason users may be seeing this is due to a “linking limit” placed on the number of iOS devices transferred to a single desktop wallet. Up to four iOS devices can use the one-time transfer option to move BAT from the device to one desktop wallet. If you have tried to use a fifth device (or more) to transfer funds to a single desktop wallet, you will encounter this connection error.

To resolve this, we are implementing some changes to the Rewards Internals page (Settings → Brave Rewards → Rewards Internals) that will surface and allow users to view the correct (Legacy) wallet ID on your device. From there, we will be able to determine what transferable funds (if any) are in that wallet and issue a refund for valid balances. We will make an announcement once this change is pushed into the browser.

We appreciate everyone’s patience and understanding while we are working through these issues. We will make an announcement here on Community as any fixes or changes surrounding the iOS transfer become available.

Thank you.


UPDATE (3/29/2021):
We have found the cause for users who’s iOS BAT was not transferred. Almost all users affected by this should see (or already seen) those funds appear in the browser wallet designated receive the transfer. We’re working on a final small subset of users who’s BAT is still “stuck” and should have this issue completely resolved in the next few days.


UPDATE (4/09/2021):
We appreciate everyone’s patience with this issue. At this time, almost everyone who has encountered one of these issues with iOS funds not transferring should have received the funds in their desktop wallet. A very small number of users seem to have hit a known edge case(s) and may still not have received their funds. Note that the team is diagnosing the issue and those users will still have their funds transferred properly.

If your BAT has still not transferred, you’re very likely one of those edge cases. Anyone who is still waiting on their transfer to go through at this point, please send me a DM with the following information:

  1. Make the subject line of the DM iOS transfer information so I can easily see it.
  2. Send your wallet payment ID for your iOS device, found on the by going to Menu --> Settings --> Rewards --> Rewards internalseven if you’ve already sent this to me before, please send it again to avoid any confusion.
  3. Whether or not you installed Brave and enabled Rewards on iOS after December, 15th 2020.

Thank you for your patience and understanding.