Not Receiving Desktop Ads

Description of the issue:
Hello,
I noticed that I don’t seem to receive the Windows 10 “integrated” ads on my desktop version of Brave. 100% of my BAT that I have received on desktop is from the ads that show on the new tab screen. On my mobile version of Brave, I have received almost 3x as much BAT in about half the amount of time, because the ad notifications there aren’t broken. This tells me that it isn’t something with my IP, or lack of relevant ads, but rather some kind of bug with the desktop version.

It’s also not an issue of me not using the browser - I work from home, and since our IT wants to lower the amount of bandwidth we are using on the company network with the spike in remote workforce due to COVID, I do almost 100% of my browsing on my own personal desktop PC with Brave, while using a remote desktop application on my other screens to remote into work. So Brave is up and running and being actively used for at least 8 hours every workday, and usually more like 10-12 hours. Also it’s worth noting that I don’t think it’s my settings, I have the maximum ads enabled per hour (5), no auto contribute/tipping, and I’ve even disabled Brave Ads and re-enabled them, yet the issue persists.

I’ve done a lot of research to try to fix this, but nothing has worked. Originally I had the built-in Windows notifications turned off. I followed the info on this topic: No ads on windows 10 and re-enabled windows notifications. After that, I used https://www.bennish.net/web-notifications.html to force Brave to show me a notification, and it worked. So I can definitely receive these ads, but Brave doesn’t seem to be serving them up to me for some reason.

I have also tried the steps in this topic: UPDATED : Few Tips for Those Who is Not Receiving ADs but they have not solved my issue.

How can this issue be reproduced?

  1. Browse the internet using Brave on Windows 10
  2. After several hours, check your recent ads history
  3. Recent ads history only has a couple of ads that were on the new tabs page, no notification ads have been received

Expected result:
Notification ads would have been received

Brave Version( check About Brave):
Version 1.21.74 Chromium: 89.0.4389.72 (Official Build) (64-bit)

nothing of that worked? :thinking:
check this link https://sampson.codes/brave/ads/my_region/

and my experience

Thanks JohnDproof. I double checked with the link you provided, and I have a very long page full of relevant ad campaigns for my region.

I did a completely fresh install of Brave - I uninstalled my original version, restarted Windows 10, installed a fresh copy of Brave, and then restarted Windows 10 again. However I am still having the same issue.

I am hesitant to start a new profile/uphold wallet - will this wipe any of my pending BAT?
If anyone has anything else to try, I’m all ears.

Thank you

no, the profiles are independent of each other, the new one was to see if the rewards feature worked correctly.

lets try another thing since it seems the problem isn’t your region or campaign availability, maybe the browser think the ads are not relevant to you? ads faq, most of the ads I receive are about crypto currencies or related services.

do some searches about crypto stuff for some days to see what happen :grimace:

1 Like

Crypto stuff is already a pretty large portion of my browsing history anyways.

Good news is that I started receiving ads last night! I don’t know why it didn’t happen sooner than that, but they are indeed working at least.

1 Like

For anyone who may be looking at this in the future, the complete reinstall seems to be what did the trick, at least after doing the steps that I linked in the original post. I’ve now re-enabled all of my extensions that I had before, one by one, making sure that I could still get notification ads after each one was enabled, and I am still getting ads now after finally getting them all re-enabled.

1 Like