Not getting any search results

Description of the issue:
When I type anything into the browser bar It no longer gives me any search results. I only get reddit. Also Brave keeps shutting down and then I get a pop up that says “this is embarrassing, would you like to open up the previous page. It happens 50-60 times a day. I’ve had to go back to using safari which I hate!
Steps to Reproduce (add as many as necessary): 1. 2. 3.
Type anything into the bar and I only get reddit; nothing else. When I click ‘next page’ there isn’t even the reddit, it’s just blank.
Actual Result (gifs and screenshots are welcome!):

Expected result:
I expected museums, articles and photos of modern art
Reproduces how often:
Every time I try to use it.
Operating System and Brave Version(See the About Brave page in the main menu):
IOS ipad pro. It works before the last update.

Additional Information:

1 Like

I have been having this exact problem for the last 14 hours. I have an iPhone XS. Never previously had a problem with Brave.

1 Like

Same here, no search results

1 Like

Same issue- I either get nothing or only “discussion” threads from Reddit and a pop-up telling me the “discussions” feature is new (every single time). And when I disable the discussions feature, it gives me a blank screen.

1 Like

Any chance of a response on this, Brave? The issue continues & I have been forced to download the fake privacy browser Duckduckgo as a temporary solution.

I just tried to replicate your search issue on my iPhone but with no luck.

Let me ask:

  • Are you using a VPN?

  • Have you tried to clear cookies?

  • What version of iOS are you using?

  • Specifically, what version of Brave are you using?

In regards to this, might help if you can try to get crash report info. Instructions are shared at but I’ll also type it below:

  1. Go to Settings on your device (not on Brave, but on your iPhone or iPad)
  2. Go to Analytics & Improvements
  3. Click on Analytics Data
  4. In the search bar on top, look for Client, this will be Brave. You will be looking for something that looks like Client-2023-15-XXXXXX.ips NOTE: (Do not pay mind to Client.wakeups_resource)
  5. Either click Share on the top right and then get method. Though when I tried this, it didn’t copy/paste for some reason. So you may need to copy/paste everything manually by highlighting. Guess go for whichever is easier for you.
  6. Share those details here.
1 Like

Is it safe for me to share it here? I don’t want someone getting access to my info.

1 Like

Hey man I was having the same issue. I opened up the settings, went to the Brave shield and turned off the “cross-site tracking” and it fixed the issue. I turned it back on afterwards and it stayed fixed.


This is a really unfortunate problem from what, prior to this, was the perfect browser. It seems that users are not universally affected but I now hear that two friends have the same overall problem (searches don’t work; they are directed to reddit history). Both friends are using more recent iphones than mine. Not good.

@Teddy-Fines question is, did you try what JakeMars had said just above you? Also, keep in mind that it’s the latest iOS 16.4 update that seems to be causing issues all of a sudden. Something about that system update is clashing with Brave’s settings within Shields. Usually just turning off Block Cross-Site Trackers is fixing things.

That worked, thank you!

Yes, turning off and back on the block cross-site trackers fixed the search problem but not the crashing. Thank you!

thanks for the reply. the above fix didn’t work for me; however i have just tried a search & everything is working as normal. let’s hope that’s the end of the problem - thanks for your attention to the topic. duckduckgo now deleted :fist:t5:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.